summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-04-14 11:33:52 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-04-14 11:54:34 +0300
commit6b299be23c290f5d771e8492f938d3a5df5afa4c (patch)
treec392bf6211f6763c931c722ddc14d5dc9f5638dd /dev-libs/dqlite/dqlite-1.10.0.ebuild
parentprofiles/arch/riscv: unmask USE=hugepages for sys-apps/nvme-cli (diff)
downloadgentoo-6b299be23c290f5d771e8492f938d3a5df5afa4c.tar.gz
gentoo-6b299be23c290f5d771e8492f938d3a5df5afa4c.tar.bz2
gentoo-6b299be23c290f5d771e8492f938d3a5df5afa4c.zip
dev-libs/dqlite: add 1.10.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/dqlite/dqlite-1.10.0.ebuild')
-rw-r--r--dev-libs/dqlite/dqlite-1.10.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/dqlite/dqlite-1.10.0.ebuild b/dev-libs/dqlite/dqlite-1.10.0.ebuild
new file mode 100644
index 000000000000..a3fe7ae6c8ba
--- /dev/null
+++ b/dev-libs/dqlite/dqlite-1.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Embeddable, replicated and fault tolerant SQL engine"
+HOMEPAGE="https://dqlite.io/ https://github.com/canonical/dqlite"
+SRC_URI="https://github.com/canonical/dqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/libuv:=
+ >=dev-libs/raft-0.13.0"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/raft-0.13.0[lz4,test] )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-debug
+ --disable-sanitize
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}