summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-06-10 08:16:11 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-10 08:16:49 +0300
commit46b1048c257e1074ddaaaaa6ee88ffbac431a6d7 (patch)
tree6365bfbce246901150dd933f209d28ef044d5eda /dev-libs/efl
parentdev-ruby/test-unit: add 3.3.6 (diff)
downloadgentoo-46b1048c257e1074ddaaaaa6ee88ffbac431a6d7.tar.gz
gentoo-46b1048c257e1074ddaaaaa6ee88ffbac431a6d7.tar.bz2
gentoo-46b1048c257e1074ddaaaaa6ee88ffbac431a6d7.zip
dev-libs/efl: fix arm[-neon] CPU builds, #722552
Closes: https://bugs.gentoo.org/722552 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/efl')
-rw-r--r--dev-libs/efl/efl-1.24.2.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/dev-libs/efl/efl-1.24.2.ebuild b/dev-libs/efl/efl-1.24.2.ebuild
index 397a184692d9..d7832a453ac8 100644
--- a/dev-libs/efl/efl-1.24.2.ebuild
+++ b/dev-libs/efl/efl-1.24.2.ebuild
@@ -12,11 +12,12 @@ SRC_URI="https://download.enlightenment.org/rel/libs/${PN}/${P}.tar.xz"
LICENSE="BSD-2 GPL-2 LGPL-2.1 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="+X bmp connman dds debug doc drm +eet elogind examples fbcon +fontconfig
- fribidi gif gles2 gnutls glib +gstreamer harfbuzz hyphen ibus ico libressl
- lua +luajit jpeg2k json nls mono opengl +pdf physics pmaps postscript psd
- pulseaudio raw scim sdl +sound +ssl +svg +system-lz4 systemd tga tgv tiff
- tslib unwind v4l vnc wayland webp xcf xim xpm xpresent zeroconf"
+IUSE="+X bmp connman cpu_flags_arm_neon dds debug doc drm +eet elogind examples
+ fbcon +fontconfig fribidi gif gles2 gnutls glib +gstreamer harfbuzz hyphen
+ ibus ico libressl lua +luajit jpeg2k json nls mono opengl +pdf physics
+ pmaps postscript psd pulseaudio raw scim sdl +sound +ssl +svg +system-lz4
+ systemd tga tgv tiff tslib unwind v4l vnc wayland webp xcf xim xpm xpresent
+ zeroconf"
REQUIRED_USE="
?? ( elogind systemd )
@@ -244,6 +245,11 @@ src_configure() {
fi
emesonargs+=( -D lua-interpreter="${luaChoice}" )
+ # Not all arm CPU's have neon instruction set, #722552
+ if use arm && ! use cpu_flags_arm_neon; then
+ emesonargs+=( -D native-arch-optimization=false )
+ fi
+
meson_src_configure
}