summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/eina
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/eina')
-rw-r--r--dev-libs/eina/Manifest2
-rw-r--r--dev-libs/eina/eina-1.7.10.ebuild85
-rw-r--r--dev-libs/eina/eina-1.7.9.ebuild85
-rw-r--r--dev-libs/eina/eina-9999.ebuild85
-rw-r--r--dev-libs/eina/metadata.xml66
5 files changed, 323 insertions, 0 deletions
diff --git a/dev-libs/eina/Manifest b/dev-libs/eina/Manifest
new file mode 100644
index 000000000000..d0b0930e5e81
--- /dev/null
+++ b/dev-libs/eina/Manifest
@@ -0,0 +1,2 @@
+DIST eina-1.7.10.tar.bz2 9703289 SHA256 6378168bfb5ccc5338b39bbc4465cb96c5751f70cdf05766fbbddaf94fb0f81a SHA512 c1195ec9f2cd79777912ba3c8b6e69a206d035c9a7f2c38762c18e3c86ec43d52f020e4dd8d0ea0c9b580aff9707cede909412260ac6d23796ddbd78eb8e280e WHIRLPOOL 0110c7cb19741be9194c80284543f0790a2b7d4e073f7a8e2bfa1a44920207ebd83aad831ea9623401ecf3a6ea1b33ef35b1fb344abc3c935ac009d9f646dcd4
+DIST eina-1.7.9.tar.bz2 9704705 SHA256 b032dd390b4d9f0f0db4b63890cdfc4a5d515b8dfef87f94073e477ff31adf76 SHA512 4f19ee5910595e7e907a2f99ce3adbd18faa7bf462ae4c44d13297a7e1f32bdd24e9b33aa8df33c166e9c3d321eed655b908100695f7eeffe42f24163faba378 WHIRLPOOL 9309779e851156388a801fb262226e737f6704162bed0cd1a0f1850a2d0d20c863db560dbd8af642aafb9982ab5f16e63b3bda7291182004e5cb86ef3c4c9458
diff --git a/dev-libs/eina/eina-1.7.10.ebuild b/dev-libs/eina/eina-1.7.10.ebuild
new file mode 100644
index 000000000000..1ab08927b396
--- /dev/null
+++ b/dev-libs/eina/eina-1.7.10.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's data types library (list, hash, etc) in C"
+
+LICENSE="LGPL-2.1"
+IUSE="altivec debug default-mempool cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test valgrind"
+
+MEMPOOLS=(
+ @buddy
+ +@chained-pool
+ # Looks like ememoa is a dead project?
+ #@ememoa-fixed
+ #@ememoa-unknown
+ @fixed-bitmap
+ +@one-big
+ @pass-through
+)
+IUSE_MEMPOOLS=${MEMPOOLS[@]/@/mempool-}
+IUSE+=" ${IUSE_MEMPOOLS}"
+
+RDEPEND="valgrind? ( dev-util/valgrind )"
+# mempool-ememoa-fixed? ( sys-libs/ememoa )
+# mempool-ememoa-unknown? ( sys-libs/ememoa )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-libs/check
+ dev-libs/glib
+ dev-util/lcov
+ )"
+
+src_configure() {
+ # Evas benchmark is broken!
+ E_ECONF=(
+ $(use_enable altivec cpu-altivec)
+ $(use_enable !debug amalgamation)
+ $(use_enable debug stringshare-usage)
+ $(use_enable debug assert)
+ $(use debug || echo " --with-internal-maximum-log-level=2")
+ $(use_enable default-mempool)
+ $(use_enable doc)
+ $(use_enable cpu_flags_x86_mmx cpu-mmx)
+ $(use_enable cpu_flags_x86_sse cpu-sse)
+ $(use_enable cpu_flags_x86_sse2 cpu-sse2)
+ $(use test && echo " --disable-amalgamation")
+ $(use_enable test e17)
+ $(use_enable test tests)
+ $(use_enable test benchmark)
+ $(use test && echo " --with-internal-maximum-log-level=6")
+ $(use_enable valgrind)
+ --enable-magic-debug
+ --enable-safety-checks
+ )
+
+ #if use mempool-ememoa-fixed || use mempool-ememoa-unknown ; then
+ # E_ECONF+=( --enable-ememoa )
+ #else
+ E_ECONF+=( --disable-ememoa )
+ #fi
+
+ local m mempool_arg='static'
+ if use debug ; then
+ mempool_arg='yes'
+ fi
+ for m in ${IUSE_MEMPOOLS//+} ; do
+ E_ECONF+=( $(use_enable ${m} ${m} ${mempool_argT}) )
+ done
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eina/eina-1.7.9.ebuild b/dev-libs/eina/eina-1.7.9.ebuild
new file mode 100644
index 000000000000..1ab08927b396
--- /dev/null
+++ b/dev-libs/eina/eina-1.7.9.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's data types library (list, hash, etc) in C"
+
+LICENSE="LGPL-2.1"
+IUSE="altivec debug default-mempool cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test valgrind"
+
+MEMPOOLS=(
+ @buddy
+ +@chained-pool
+ # Looks like ememoa is a dead project?
+ #@ememoa-fixed
+ #@ememoa-unknown
+ @fixed-bitmap
+ +@one-big
+ @pass-through
+)
+IUSE_MEMPOOLS=${MEMPOOLS[@]/@/mempool-}
+IUSE+=" ${IUSE_MEMPOOLS}"
+
+RDEPEND="valgrind? ( dev-util/valgrind )"
+# mempool-ememoa-fixed? ( sys-libs/ememoa )
+# mempool-ememoa-unknown? ( sys-libs/ememoa )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-libs/check
+ dev-libs/glib
+ dev-util/lcov
+ )"
+
+src_configure() {
+ # Evas benchmark is broken!
+ E_ECONF=(
+ $(use_enable altivec cpu-altivec)
+ $(use_enable !debug amalgamation)
+ $(use_enable debug stringshare-usage)
+ $(use_enable debug assert)
+ $(use debug || echo " --with-internal-maximum-log-level=2")
+ $(use_enable default-mempool)
+ $(use_enable doc)
+ $(use_enable cpu_flags_x86_mmx cpu-mmx)
+ $(use_enable cpu_flags_x86_sse cpu-sse)
+ $(use_enable cpu_flags_x86_sse2 cpu-sse2)
+ $(use test && echo " --disable-amalgamation")
+ $(use_enable test e17)
+ $(use_enable test tests)
+ $(use_enable test benchmark)
+ $(use test && echo " --with-internal-maximum-log-level=6")
+ $(use_enable valgrind)
+ --enable-magic-debug
+ --enable-safety-checks
+ )
+
+ #if use mempool-ememoa-fixed || use mempool-ememoa-unknown ; then
+ # E_ECONF+=( --enable-ememoa )
+ #else
+ E_ECONF+=( --disable-ememoa )
+ #fi
+
+ local m mempool_arg='static'
+ if use debug ; then
+ mempool_arg='yes'
+ fi
+ for m in ${IUSE_MEMPOOLS//+} ; do
+ E_ECONF+=( $(use_enable ${m} ${m} ${mempool_argT}) )
+ done
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eina/eina-9999.ebuild b/dev-libs/eina/eina-9999.ebuild
new file mode 100644
index 000000000000..1ab08927b396
--- /dev/null
+++ b/dev-libs/eina/eina-9999.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's data types library (list, hash, etc) in C"
+
+LICENSE="LGPL-2.1"
+IUSE="altivec debug default-mempool cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test valgrind"
+
+MEMPOOLS=(
+ @buddy
+ +@chained-pool
+ # Looks like ememoa is a dead project?
+ #@ememoa-fixed
+ #@ememoa-unknown
+ @fixed-bitmap
+ +@one-big
+ @pass-through
+)
+IUSE_MEMPOOLS=${MEMPOOLS[@]/@/mempool-}
+IUSE+=" ${IUSE_MEMPOOLS}"
+
+RDEPEND="valgrind? ( dev-util/valgrind )"
+# mempool-ememoa-fixed? ( sys-libs/ememoa )
+# mempool-ememoa-unknown? ( sys-libs/ememoa )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-libs/check
+ dev-libs/glib
+ dev-util/lcov
+ )"
+
+src_configure() {
+ # Evas benchmark is broken!
+ E_ECONF=(
+ $(use_enable altivec cpu-altivec)
+ $(use_enable !debug amalgamation)
+ $(use_enable debug stringshare-usage)
+ $(use_enable debug assert)
+ $(use debug || echo " --with-internal-maximum-log-level=2")
+ $(use_enable default-mempool)
+ $(use_enable doc)
+ $(use_enable cpu_flags_x86_mmx cpu-mmx)
+ $(use_enable cpu_flags_x86_sse cpu-sse)
+ $(use_enable cpu_flags_x86_sse2 cpu-sse2)
+ $(use test && echo " --disable-amalgamation")
+ $(use_enable test e17)
+ $(use_enable test tests)
+ $(use_enable test benchmark)
+ $(use test && echo " --with-internal-maximum-log-level=6")
+ $(use_enable valgrind)
+ --enable-magic-debug
+ --enable-safety-checks
+ )
+
+ #if use mempool-ememoa-fixed || use mempool-ememoa-unknown ; then
+ # E_ECONF+=( --enable-ememoa )
+ #else
+ E_ECONF+=( --disable-ememoa )
+ #fi
+
+ local m mempool_arg='static'
+ if use debug ; then
+ mempool_arg='yes'
+ fi
+ for m in ${IUSE_MEMPOOLS//+} ; do
+ E_ECONF+=( $(use_enable ${m} ${m} ${mempool_argT}) )
+ done
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eina/metadata.xml b/dev-libs/eina/metadata.xml
new file mode 100644
index 000000000000..76fbac87e982
--- /dev/null
+++ b/dev-libs/eina/metadata.xml
@@ -0,0 +1,66 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<use>
+ <flag name="mempool-buddy">Compile "buddy" memory pool allocation.</flag>
+ <flag name="mempool-chained-pool">Compile "chained-pool" memory pool allocation.</flag>
+ <flag name="mempool-fixed-bitmap">Compile "fixed-bitmap" memory pool allocation.</flag>
+ <flag name="mempool-one-big">Compile "one-big" memory pool allocation.</flag>
+ <flag name="mempool-pass-through">Compile "pass-through" (system's malloc) memory pool allocation.</flag>
+ <flag name="default-mempool">By default use system's allocator (pass-through) instead of custom choice for Eina's own data structures.</flag>
+ <flag name="valgrind">Compile in valgrind hints for smoother integration.</flag>
+</use>
+<longdescription>
+Eina is a multi-platform library that provides optimized data types
+and useful tools for projects.
+
+Among its data types, Eina provides efficient implementation of:
+
+ * double linked list with O(1) append and count;
+
+ * double linked inlist (node is built in the data) with O(1) append;
+
+ * stringshare, a pool of read-only strings that are shared in order
+ to save memory (no copies!), fast referencing and
+ pointer-comparison;
+
+ * hash table with extensible key support, ships by default with
+ string, stringshare, pointer and integer hashes by default;
+
+ * array of pointers, with O(1) count and append, configurable step
+ growing;
+
+ * red-black tree;
+
+ * sparse matrix;
+
+
+As for tools, it provides couple of convenience:
+
+ * generic and extensible logging system;
+
+ * easy to use dynamic module loading (on top of dlopen()) that makes
+ it easy to change to static/built-in modules;
+
+ * generic safety-checks system covering NULL pointers and other
+ incorrect conditions with logging;
+
+ * "magic" type checking that check and logs if expected magic number
+ is incorrect;
+
+ * easy to use and extensible memory allocators (mempools);
+
+ * fixed-point arithmetic;
+
+ * tile splitter and simplifier (merges);
+
+ * generic iterator pattern (how to walk in one direction), just
+ implement the given API;
+
+ * generic accessor pattern (how to randomly access items), just
+ implement the given API;
+
+ * benchmark helpers.
+</longdescription>
+</pkgmetadata>