summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-22 11:11:09 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-22 11:11:42 +0200
commitf17b404ed37fd1cfbdd0db69d744a691dfb96956 (patch)
treead213cd1005c80ef47c950344fb89cb1c918cc6e /dev-libs/elfio
parentnet-dns/knot: add libidn2 USE flag (diff)
downloadgentoo-f17b404ed37fd1cfbdd0db69d744a691dfb96956.tar.gz
gentoo-f17b404ed37fd1cfbdd0db69d744a691dfb96956.tar.bz2
gentoo-f17b404ed37fd1cfbdd0db69d744a691dfb96956.zip
dev-libs/elfio: EAPI 6 bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs/elfio')
-rw-r--r--dev-libs/elfio/elfio-1.0.3-r1.ebuild (renamed from dev-libs/elfio/elfio-1.0.3.ebuild)17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-libs/elfio/elfio-1.0.3.ebuild b/dev-libs/elfio/elfio-1.0.3-r1.ebuild
index aeb90436b2b8..8deb15fb6f8d 100644
--- a/dev-libs/elfio/elfio-1.0.3.ebuild
+++ b/dev-libs/elfio/elfio-1.0.3-r1.ebuild
@@ -1,29 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils autotools
+EAPI=6
-MY_P=ELFIO-${PV}
+inherit autotools
+
+MY_P="ELFIO-${PV}"
DESCRIPTION="ELF reader and producer implemented as a C++ library"
HOMEPAGE="http://elfio.sourceforge.net/"
SRC_URI="mirror://sourceforge/elfio/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+PATCHES=( "${FILESDIR}/${P}-shared.patch" )
- epatch "${FILESDIR}"/${P}-shared.patch
+src_prepare() {
+ default
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install
dodoc AUTHORS NEWS README
}