summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-08-23 13:55:01 +0300
committerMart Raudsepp <leio@gentoo.org>2020-08-23 13:55:37 +0300
commit33d8a674f9a97a211f42ac363dd14fd8060faa3d (patch)
tree4d1f6ab3d925808632f33389b33fb3c64b093c3a /dev-libs/folks
parentsys-libs/glibc: revert "disable multiarch on ppc32" (diff)
downloadgentoo-33d8a674f9a97a211f42ac363dd14fd8060faa3d.tar.gz
gentoo-33d8a674f9a97a211f42ac363dd14fd8060faa3d.tar.bz2
gentoo-33d8a674f9a97a211f42ac363dd14fd8060faa3d.zip
dev-libs/folks: bump to 0.14.0, re-enable tests
Package-Manager: Portage-2.3.103, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/folks')
-rw-r--r--dev-libs/folks/Manifest1
-rw-r--r--dev-libs/folks/files/0.14.0-conditional-tests.patch72
-rw-r--r--dev-libs/folks/folks-0.14.0.ebuild100
3 files changed, 173 insertions, 0 deletions
diff --git a/dev-libs/folks/Manifest b/dev-libs/folks/Manifest
index 08bba6a984ab..cbb6cbc95ccf 100644
--- a/dev-libs/folks/Manifest
+++ b/dev-libs/folks/Manifest
@@ -1 +1,2 @@
DIST folks-0.13.1.tar.xz 515584 BLAKE2B fe4e368e60dd41a72f449f130993eb7b8792b2a38218ff7117a8e5ec192d53d2b8f5ab09a2318267cf2fd7a717048b8715289b2f411c59846c6c98235ec32149 SHA512 b134172077bed1655cd7f24b1402ed347d405b22114c33d6638040a5e475632ea33cde898a08fc143eaefc7057d4b6dccceac7e797e1976fdf88c58764818afe
+DIST folks-0.14.0.tar.xz 520924 BLAKE2B 3154e0a7e6fe8c60aa81f4772af2b9d09b88785187c87e93869f668af46549383866cfa2e50d3d29009d0acb77c26cd852c7c9a3c6188ff3e5ef53c06b11b781 SHA512 94dc025668ac34df203ea351430bf82dddb4e275d936e2b959a1b9a4cf0fff0218a4baa7d3a89c152a2cb21a94250d731c8e7470d50ac4b658fbe1448974a69e
diff --git a/dev-libs/folks/files/0.14.0-conditional-tests.patch b/dev-libs/folks/files/0.14.0-conditional-tests.patch
new file mode 100644
index 000000000000..2c64ecf6610f
--- /dev/null
+++ b/dev-libs/folks/files/0.14.0-conditional-tests.patch
@@ -0,0 +1,72 @@
+From b9e27e284c481e876370e2eb73f95d0953fb9cda Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 23 Aug 2020 11:49:44 +0300
+Subject: [PATCH] meson: Allow disabling build of tests
+
+Fixes https://gitlab.gnome.org/GNOME/folks/-/issues/121
+---
+ meson.build | 21 +++++++++++++--------
+ meson_options.txt | 1 +
+ 2 files changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 53d7dcc6..123edb5c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -54,6 +54,7 @@ folks_backend_dir = get_option('libdir') / 'folks' / '@0@'.format(folks_module_v
+ bluez_backend_enabled = get_option('bluez_backend')
+ docs_enabled = get_option('docs')
+ eds_backend_enabled = get_option('eds_backend')
++tests_enabled = get_option('tests')
+ installed_tests_enabled = get_option('installed_tests')
+ ofono_backend_enabled = get_option('ofono_backend')
+ telepathy_backend_enabled = get_option('telepathy_backend')
+@@ -130,13 +131,15 @@ endif
+
+ if bluez_backend_enabled
+ libebook_dep = dependency('libebook-1.2', version: '>=' + min_eds_version)
+- # Needed for the BlueZ tests
+- pymod = import('python')
+- py_installation = pymod.find_installation('python3',
+- modules: [
+- 'dbusmock',
+- ],
+- )
++ if tests_enabled
++ # Needed for the BlueZ tests
++ pymod = import('python')
++ py_installation = pymod.find_installation('python3',
++ modules: [
++ 'dbusmock',
++ ],
++ )
++ endif
+ endif
+
+ if import_tool_enabled
+@@ -233,7 +236,9 @@ subdir('tools')
+ subdir('po')
+
+ # Tests
+-subdir('tests')
++if tests_enabled
++ subdir('tests')
++endif
+
+ if docs_enabled
+ subdir('docs')
+diff --git a/meson_options.txt b/meson_options.txt
+index 43cd586a..62a9603c 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -11,6 +11,7 @@ option('inspect_tool', type: 'boolean', value: true, description: 'Enable buildi
+ # Profiling
+ option('profiling', type: 'boolean', value: false, description: 'Enable profiling code')
+ # Test options
++option('tests', type: 'boolean', value: true, description: 'Build tests programs')
+ option('installed_tests', type: 'boolean', value: false, description: 'Install test programs')
+ # Docs
+ option('docs', type: 'boolean', value: false, description: 'Enable documentation generation')
+--
+2.20.1
+
diff --git a/dev-libs/folks/folks-0.14.0.ebuild b/dev-libs/folks/folks-0.14.0.ebuild
new file mode 100644
index 000000000000..3da8c1c10c3f
--- /dev/null
+++ b/dev-libs/folks/folks-0.14.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MAX_API_VERSION="0.48"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Library for aggregating people from multiple sources"
+HOMEPAGE="https://wiki.gnome.org/Projects/Folks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/25" # subslot = libfolks soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+IUSE="bluetooth eds +telepathy test tracker utils"
+REQUIRED_USE="bluetooth? ( eds )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libgee-0.10:0.8[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ telepathy? (
+ >=net-libs/telepathy-glib-0.19.9
+ dev-libs/dbus-glib
+ )
+ tracker? ( app-misc/tracker:0/2.0 )
+ eds? ( >=gnome-extra/evolution-data-server-3.33.2:= )
+ dev-libs/libxml2:2
+ utils? ( sys-libs/readline:0= )
+"
+# telepathy-mission-control needed at runtime; it is used by the telepathy
+# backend via telepathy-glib's AccountManager binding.
+RDEPEND="${DEPEND}
+ bluetooth? ( >=net-wireless/bluez-5[obex] )
+ telepathy? ( net-im/telepathy-mission-control )
+"
+BDEPEND="
+ >=dev-util/meson-0.49
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ telepathy? ( net-libs/telepathy-glib[vala] )
+ eds? ( gnome-extra/evolution-data-server[vala] )
+ test? ( sys-apps/dbus
+ ${PYTHON_DEPS}
+ bluetooth? ( $(python_gen_any_dep 'dev-python/dbusmock[${PYTHON_USEDEP}]') )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-conditional-tests.patch
+)
+
+python_check_deps() {
+ if use test && use bluetooth; then
+ has_version "dev-python/dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+pkg_setup() {
+ use test && use bluetooth && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+ # TODO: All tracker tests fail with SIGTRAP for some reason - investigate
+ sed -e '/subdir.*tracker/d' -i tests/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use bluetooth bluez_backend)
+ $(meson_use eds eds_backend)
+ $(meson_use eds ofono_backend)
+ $(meson_use telepathy telepathy_backend)
+ $(meson_use tracker tracker_backend)
+ -Dzeitgeist=false # last rited package
+ -Dimport_tool=true
+ $(meson_use utils inspect_tool)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ -Ddocs=false # Needs find_program sedding to specific version; only dev docs, don't bother
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}