summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-04-29 13:35:05 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-05-10 09:54:01 +0300
commit5d8fc452586277aecda09b79d30e44b564404c1e (patch)
tree11efd498f4a2eba0a984d11503d3204ad5affb77 /dev-libs/fstrm
parentsci-mathematics/gimps: Version bump to 30.6 build 4 (diff)
downloadgentoo-5d8fc452586277aecda09b79d30e44b564404c1e.tar.gz
gentoo-5d8fc452586277aecda09b79d30e44b564404c1e.tar.bz2
gentoo-5d8fc452586277aecda09b79d30e44b564404c1e.zip
dev-libs/fstrm: Version updated to 0.6.1.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/20591 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/fstrm')
-rw-r--r--dev-libs/fstrm/Manifest1
-rw-r--r--dev-libs/fstrm/fstrm-0.6.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/fstrm/Manifest b/dev-libs/fstrm/Manifest
index 839b14098c7a..e3728779fae9 100644
--- a/dev-libs/fstrm/Manifest
+++ b/dev-libs/fstrm/Manifest
@@ -1 +1,2 @@
DIST fstrm-0.6.0.tar.gz 135214 BLAKE2B 237b371450ea2e92e466aaeab2d6ebf9ba7c6bbf14d1517431818b01a2609c1765299bb576bb3a4a3a99a9ce7644992c3f5eaf82c01d903a1bad358d49ed47b4 SHA512 8e327f40fb49b36998d8bb9353b30b9924630b85adf1e4462ce4b456daa7eea727892a59f43ddd48de5bf5059a450fef54726b09af6d7f210fa182c4055d65f4
+DIST fstrm-0.6.1.tar.gz 135425 BLAKE2B 607852bd6bd18d2dc4e862c7425882274710674da1edb3a525b409f5eff9cb46748f8e5b7b1e88ab180ddfed7a19ee41aaa9551d70331ac80ff178ffa0b4ca98 SHA512 7bf2728e2d0d1fdbd4e93069ddb03a01dc56909dbac57650ed530c80f761170b257c7191a3d789d4661df1f09c15594f20ec93a4eb5e5deb7ea3a7eabe56806c
diff --git a/dev-libs/fstrm/fstrm-0.6.1.ebuild b/dev-libs/fstrm/fstrm-0.6.1.ebuild
new file mode 100644
index 000000000000..ca1e8ecd295b
--- /dev/null
+++ b/dev-libs/fstrm/fstrm-0.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Frame Streams implementation in C"
+HOMEPAGE="https://github.com/farsightsec/fstrm"
+SRC_URI="https://github.com/farsightsec/fstrm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static-libs utils"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="utils? ( dev-libs/libevent:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable utils programs)
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}