summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-26 14:08:58 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-26 14:18:09 -0400
commit2e663bd0db9b0cc1bdc6136bc392230f759a4d48 (patch)
tree756d92fcb4fc4f21fc8660daeb6417cc45bb8647 /dev-libs/gf2x/gf2x-1.3.0.ebuild
parentdev-lang/python: arm stable wrt bug #707822 (diff)
downloadgentoo-2e663bd0db9b0cc1bdc6136bc392230f759a4d48.tar.gz
gentoo-2e663bd0db9b0cc1bdc6136bc392230f759a4d48.tar.bz2
gentoo-2e663bd0db9b0cc1bdc6136bc392230f759a4d48.zip
dev-libs/gf2x: new version 1.3.0.
Standard version bump along with some ebuild improvements: * EAPI=7. * Dropped the unused eutils and replaced the ltprune eclasses. * Added the new Gitlab instance to HOMEPAGE. * Added a GCC-10.x compatibility patch already merged upstream. * Updated the subslot to match the major soname component. Closes: https://bugs.gentoo.org/719612 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-libs/gf2x/gf2x-1.3.0.ebuild')
-rw-r--r--dev-libs/gf2x/gf2x-1.3.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/gf2x/gf2x-1.3.0.ebuild b/dev-libs/gf2x/gf2x-1.3.0.ebuild
new file mode 100644
index 000000000000..4763099d4a33
--- /dev/null
+++ b/dev-libs/gf2x/gf2x-1.3.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="C/C++ routines for fast arithmetic in GF(2)[x]"
+HOMEPAGE="https://gitlab.inria.fr/thome/gf2x/ http://gforge.inria.fr/projects/gf2x/"
+# The Gitlab release is missing the autotools files.
+SRC_URI="https://gforge.inria.fr/frs/download.php/38243/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # soname major version, defined in configure.ac
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="fft static-libs custom-tune"
+IUSE_CPU_FLAGS=" pclmul sse2 sse3 sse4_1 ssse3"
+IUSE+=" ${IUSE_CPU_FLAGS// / cpu_flags_x86_}"
+
+PATCHES=( "${FILESDIR}/fno-common.patch" )
+
+src_prepare() {
+ default
+ # fix for cross-compiling, avoid ABI detection
+ sed -e 's/VERIFY_WORDSIZE(\[$ABI\].*/echo "skipping ABI check"/' \
+ -e 's/AC_MSG_ERROR(\[already_t.*/echo "skipping ABI check"/' \
+ -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable cpu_flags_x86_sse3 sse3) \
+ $(use_enable cpu_flags_x86_ssse3 ssse3) \
+ $(use_enable cpu_flags_x86_sse4_1 sse41) \
+ $(use_enable cpu_flags_x86_pclmul pclmul) \
+ $(use_enable fft fft-interface) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use custom-tune; then
+ einfo "Starting tuning"
+ emake tune-lowlevel
+ emake tune-toom
+ use fft && emake tune-fft
+ fi
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}