summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-06-05 22:53:44 +0200
committerSam James <sam@gentoo.org>2021-06-05 21:26:58 +0000
commit9c7b2300d3e47284bbe33a18a20ae80ec5c334c1 (patch)
treeefe23dbc763caa4034166cbea0050c6e7f6adcb6 /dev-libs/gf2x/gf2x-1.3.0.ebuild
parentx11-wm/herbstluftwm: sync -9999 with latest release ebuild (diff)
downloadgentoo-9c7b2300d3e47284bbe33a18a20ae80ec5c334c1.tar.gz
gentoo-9c7b2300d3e47284bbe33a18a20ae80ec5c334c1.tar.bz2
gentoo-9c7b2300d3e47284bbe33a18a20ae80ec5c334c1.zip
dev-libs/gf2x: add missing includes
Add include statement for MIN and MAX declarations Closes: https://bugs.gentoo.org/719982 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/21137 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/gf2x/gf2x-1.3.0.ebuild')
-rw-r--r--dev-libs/gf2x/gf2x-1.3.0.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-libs/gf2x/gf2x-1.3.0.ebuild b/dev-libs/gf2x/gf2x-1.3.0.ebuild
index 0ff8c7a7a428..d879f80de12f 100644
--- a/dev-libs/gf2x/gf2x-1.3.0.ebuild
+++ b/dev-libs/gf2x/gf2x-1.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,7 +17,10 @@ IUSE="fft static-libs custom-tune"
IUSE_CPU_FLAGS=" pclmul sse2 sse3 sse4_1 ssse3"
IUSE+=" ${IUSE_CPU_FLAGS// / cpu_flags_x86_}"
-PATCHES=( "${FILESDIR}/fno-common.patch" )
+PATCHES=(
+ "${FILESDIR}/fno-common.patch"
+ "${FILESDIR}/${P}-0001-src-tunefft.c-add-include-statement-for-MIN-and-MAX.patch"
+)
src_prepare() {
default