summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/gf2x
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/gf2x')
-rw-r--r--dev-libs/gf2x/Manifest2
-rw-r--r--dev-libs/gf2x/gf2x-1.0-r1.ebuild39
-rw-r--r--dev-libs/gf2x/gf2x-1.1.ebuild39
-rw-r--r--dev-libs/gf2x/metadata.xml14
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-libs/gf2x/Manifest b/dev-libs/gf2x/Manifest
new file mode 100644
index 000000000000..566ed912f904
--- /dev/null
+++ b/dev-libs/gf2x/Manifest
@@ -0,0 +1,2 @@
+DIST gf2x-1.0.tar.gz 460810 SHA256 b64ffa9275cc2e995d37bcecbcdce9ba1df1e17d3d31d8685128d00df305e753 SHA512 f4658698972e31428d8349b423762e9ef5aaeb52d8081c9831baa4eb066737ab3e9667a700d5df79e0f0df2626db39f2f994df17da14719506d44dbb9b33af40 WHIRLPOOL 1f4bc9deca4a0e08555800f327b4ad76e58564523271dac29b337fa757e4aebcedec0ed9bfb738e0a24892ac25d9d8d65315a12f462e91d680a908ab1b35b050
+DIST gf2x-1.1.tar.gz 496708 SHA256 0d3f01604680102a00ca34e079903cc4d5a3208afda223748979b724d358849f SHA512 052cb2152773dc114a2a80cc64cd0679c1f57eceabcdc7cc25987b8d2599fa6d4871b5bb6ff71319727411b9b5aca11e431e43eafa474a419cf306d42d22ac2c WHIRLPOOL 6336dd24f05b8f18713578b65d129e667029876b3d67ab13113140d73aa7b14f2afbd2f4f2ef15d25470589b15aad382c0efefd3f1d0e47ba5e2bada42ee0580
diff --git a/dev-libs/gf2x/gf2x-1.0-r1.ebuild b/dev-libs/gf2x/gf2x-1.0-r1.ebuild
new file mode 100644
index 000000000000..fb44c6cdb287
--- /dev/null
+++ b/dev-libs/gf2x/gf2x-1.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+PACKAGEID=27999 # hack
+
+DESCRIPTION="C/C++ routines for fast arithmetic in GF(2)[x]"
+HOMEPAGE="http://gf2x.gforge.inria.fr/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/${PACKAGEID}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bindist static-libs"
+
+src_configure() {
+ local myeconfargs=(
+ ABI=default
+ )
+
+ if use bindist ; then
+ if use x86 ; then
+ myeconfargs+=(
+ --disable-sse2
+ )
+ fi
+ if use amd64 ; then
+ myeconfargs+=(
+ --disable-pclmul
+ )
+ fi
+ fi
+
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/gf2x/gf2x-1.1.ebuild b/dev-libs/gf2x/gf2x-1.1.ebuild
new file mode 100644
index 000000000000..eda6e1b5a3af
--- /dev/null
+++ b/dev-libs/gf2x/gf2x-1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+PACKAGEID=30873 # hack
+
+DESCRIPTION="C/C++ routines for fast arithmetic in GF(2)[x]"
+HOMEPAGE="http://gf2x.gforge.inria.fr/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/${PACKAGEID}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bindist static-libs"
+
+src_configure() {
+ local myeconfargs=(
+ ABI=default
+ )
+
+ if use bindist ; then
+ if use x86 ; then
+ myeconfargs+=(
+ --disable-sse2
+ )
+ fi
+ if use amd64 ; then
+ myeconfargs+=(
+ --disable-pclmul
+ )
+ fi
+ fi
+
+ autotools-utils_src_configure
+}
diff --git a/dev-libs/gf2x/metadata.xml b/dev-libs/gf2x/metadata.xml
new file mode 100644
index 000000000000..65b8fbc6e876
--- /dev/null
+++ b/dev-libs/gf2x/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ gf2x is a C/C++ software package containing routines for fast
+ arithmetic in GF(2)[x] (multiplication, squaring, GCD) and searching
+ for irreducible/primitive trinomials.
+</longdescription>
+<use>
+ <flag name="bindist">Disable automatic fine-tuning to local
+ processor features like pclmul or sse2.</flag>
+</use>
+</pkgmetadata>