summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-07-29 05:53:53 +0300
committerMart Raudsepp <leio@gentoo.org>2017-07-29 05:53:53 +0300
commit26d779cf518de48d1e05a3cb0cb3810f2844da16 (patch)
treed823a696f11539cc08a8cfbacec060ffe3220a3f /dev-libs/gjs/gjs-1.48.6.ebuild
parentdev-db/mariadb: 10.2.7-r1 Fix GSSAPI detection patch wrt bug 626330 (diff)
downloadgentoo-26d779cf518de48d1e05a3cb0cb3810f2844da16.tar.gz
gentoo-26d779cf518de48d1e05a3cb0cb3810f2844da16.tar.bz2
gentoo-26d779cf518de48d1e05a3cb0cb3810f2844da16.zip
dev-libs/gjs: bump to 1.48.6 for a gnome-shell-3.24 crash fix
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs/gjs/gjs-1.48.6.ebuild')
-rw-r--r--dev-libs/gjs/gjs-1.48.6.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/gjs/gjs-1.48.6.ebuild b/dev-libs/gjs/gjs-1.48.6.ebuild
new file mode 100644
index 000000000000..782d4047a2a2
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.48.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 pax-utils virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.52.1
+ >=dev-libs/gobject-introspection-1.52.1:=
+
+ sys-libs/readline:0
+ dev-lang/spidermonkey:38
+ virtual/libffi
+ cairo? ( x11-libs/cairo[X] )
+ gtk? ( >=x11-libs/gtk+-3.20:3 )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+PATCHES=(
+ # Disable unittest failing without pt_BR locale, upstream bug #????
+ "${FILESDIR}"/${PV}-disable-unittest.patch
+)
+
+src_configure() {
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+ # XXX: Do NOT enable coverage, completely useless for portage installs
+ gnome2_src_configure \
+ --disable-systemtap \
+ --disable-dtrace \
+ --disable-code-coverage \
+ $(use_with cairo cairo) \
+ $(use_with gtk) \
+ $(use_with test dbus-tests) \
+ $(use_with test xvfb-tests)
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ # installation sometimes fails in parallel, bug #???
+ gnome2_src_install -j1
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ fi
+
+ # Required for gjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/gjs-console"
+}