summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-10 16:26:54 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-10 16:35:16 -0500
commitaddb8a74b03820b333d954659312ab1358b9aafa (patch)
tree1d0a79abbd89d8f6a2aba126634620d4ae87feba /dev-libs/gjs
parentdev-ml/unidecode: fix test (diff)
downloadgentoo-addb8a74b03820b333d954659312ab1358b9aafa.tar.gz
gentoo-addb8a74b03820b333d954659312ab1358b9aafa.tar.bz2
gentoo-addb8a74b03820b333d954659312ab1358b9aafa.zip
dev-libs/gjs: Version bump to 1.66.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.66.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 604957568747..c8ae00bd798d 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,2 +1,3 @@
DIST gjs-1.64.4.tar.xz 422496 BLAKE2B a96211f7240336dbb30c6965e405f59ee72e4288842837da8da8c6d3c59b7e04ebb6c7a8b0b02d38601c162ffdf1a1fef9f13e4db720c4c483f4a39dffd5dbb4 SHA512 21a15d7106ad6584fb1f02cb0a0a4cab211a3540adb8f2c03d35c211e3946b81935000a52351fedd95a18a7ff6b7f96e665fcafa3c411ff79f2b6cb332c82b42
DIST gjs-1.66.1.tar.xz 439992 BLAKE2B 2b6d25b50fd48ed8b9bb0c594321bd00525e7d6db8b348d7da5c1e10cfd588fccf5030edc93fc31da094da5a0327d4a7b26c26d18ee4284dc1ae767f7721a7b4 SHA512 601d0c645ab1586e7d770f753bf68653816dc631faf89b5e70216320f6b7707e4aaa3507111fb6ff3331f76656050e32e8b1441720bf080de957e03e4565a43f
+DIST gjs-1.66.2.tar.xz 440184 BLAKE2B 8df23470c763d65733c6fb622a1de8b8fed3e16c1ba67883b6ae0e7150a5a30a334735be39f9c68217501b7674fee8bfce6ab704c0742ae639a1bc14cdce4cd8 SHA512 2e0ca24532b3203a55089eb25de19b4b4f33166f40d1231198947057e45f364d3c7f794ff2079c1d9aee3fde9f99cd844944229d89d5e344a97254aaa42bad40
diff --git a/dev-libs/gjs/gjs-1.66.2.ebuild b/dev-libs/gjs/gjs-1.66.2.ebuild
new file mode 100644
index 000000000000..cd936bdbf15a
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.66.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.61.2:=
+ dev-lang/spidermonkey:78
+ cairo? ( x11-libs/cairo[X] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.38.1:4 )
+ test? ( sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection] )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}