summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-12-08 18:00:10 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-18 17:00:05 -0500
commitb973a74b41a709e48d7d3c707bfb7c0b104321df (patch)
tree0752acff517e6c1f77509067cff144e8018a2d68 /dev-libs/glib
parentx11-libs/libxcb: fix doc/test dependencies (diff)
downloadgentoo-b973a74b41a709e48d7d3c707bfb7c0b104321df.tar.gz
gentoo-b973a74b41a709e48d7d3c707bfb7c0b104321df.tar.bz2
gentoo-b973a74b41a709e48d7d3c707bfb7c0b104321df.zip
dev-libs/glib: drop redundant cross-compiled cache check
This test was moved to gnome2-utils.eclass so other packages can have the same behavior when cross-compiling. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/glib-2.62.6.ebuild9
-rw-r--r--dev-libs/glib/glib-2.64.5.ebuild9
-rw-r--r--dev-libs/glib/glib-2.66.2.ebuild9
-rw-r--r--dev-libs/glib/glib-2.66.3.ebuild9
4 files changed, 4 insertions, 32 deletions
diff --git a/dev-libs/glib/glib-2.62.6.ebuild b/dev-libs/glib/glib-2.62.6.ebuild
index 57adaa590548..654ff3b9d44d 100644
--- a/dev-libs/glib/glib-2.62.6.ebuild
+++ b/dev-libs/glib/glib-2.62.6.ebuild
@@ -250,14 +250,7 @@ pkg_postinst() {
gnome2_giomodule_cache_update \
|| die "Update GIO modules cache failed (for ${ABI})"
}
- if ! tc-is-cross-compiler ; then
- multilib_foreach_abi multilib_pkg_postinst
- else
- ewarn "Updating of GIO modules cache skipped due to cross-compilation."
- ewarn "You might want to run gio-querymodules manually on the target for"
- ewarn "your final image for performance reasons and re-run it when packages"
- ewarn "installing GIO modules get upgraded or added to the image."
- fi
+ multilib_foreach_abi multilib_pkg_postinst
}
pkg_postrm() {
diff --git a/dev-libs/glib/glib-2.64.5.ebuild b/dev-libs/glib/glib-2.64.5.ebuild
index 0f1b0aee616c..6e3a6137257b 100644
--- a/dev-libs/glib/glib-2.64.5.ebuild
+++ b/dev-libs/glib/glib-2.64.5.ebuild
@@ -257,14 +257,7 @@ pkg_postinst() {
gnome2_giomodule_cache_update \
|| die "Update GIO modules cache failed (for ${ABI})"
}
- if ! tc-is-cross-compiler ; then
- multilib_foreach_abi multilib_pkg_postinst
- else
- ewarn "Updating of GIO modules cache skipped due to cross-compilation."
- ewarn "You might want to run gio-querymodules manually on the target for"
- ewarn "your final image for performance reasons and re-run it when packages"
- ewarn "installing GIO modules get upgraded or added to the image."
- fi
+ multilib_foreach_abi multilib_pkg_postinst
for v in ${REPLACING_VERSIONS}; do
if ver_test "$v" "-lt" "2.63.6"; then
diff --git a/dev-libs/glib/glib-2.66.2.ebuild b/dev-libs/glib/glib-2.66.2.ebuild
index c7debe737f8a..af3ca09f98b1 100644
--- a/dev-libs/glib/glib-2.66.2.ebuild
+++ b/dev-libs/glib/glib-2.66.2.ebuild
@@ -259,14 +259,7 @@ pkg_postinst() {
gnome2_giomodule_cache_update \
|| die "Update GIO modules cache failed (for ${ABI})"
}
- if ! tc-is-cross-compiler ; then
- multilib_foreach_abi multilib_pkg_postinst
- else
- ewarn "Updating of GIO modules cache skipped due to cross-compilation."
- ewarn "You might want to run gio-querymodules manually on the target for"
- ewarn "your final image for performance reasons and re-run it when packages"
- ewarn "installing GIO modules get upgraded or added to the image."
- fi
+ multilib_foreach_abi multilib_pkg_postinst
for v in ${REPLACING_VERSIONS}; do
if ver_test "$v" "-lt" "2.63.6"; then
diff --git a/dev-libs/glib/glib-2.66.3.ebuild b/dev-libs/glib/glib-2.66.3.ebuild
index 10400fd0dd1f..6d419aa86b68 100644
--- a/dev-libs/glib/glib-2.66.3.ebuild
+++ b/dev-libs/glib/glib-2.66.3.ebuild
@@ -259,14 +259,7 @@ pkg_postinst() {
gnome2_giomodule_cache_update \
|| die "Update GIO modules cache failed (for ${ABI})"
}
- if ! tc-is-cross-compiler ; then
- multilib_foreach_abi multilib_pkg_postinst
- else
- ewarn "Updating of GIO modules cache skipped due to cross-compilation."
- ewarn "You might want to run gio-querymodules manually on the target for"
- ewarn "your final image for performance reasons and re-run it when packages"
- ewarn "installing GIO modules get upgraded or added to the image."
- fi
+ multilib_foreach_abi multilib_pkg_postinst
for v in ${REPLACING_VERSIONS}; do
if ver_test "$v" "-lt" "2.63.6"; then