summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-24 12:12:00 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-24 12:12:00 -0400
commitd0f1aa52f380ac736b5fc95cf885fb900f198e02 (patch)
treeeb49c6f3b1106bab8c157c2cc51679a14b349e83 /dev-libs/gmp/gmp-4.3.2-r1.ebuild
parentdev-libs/gmp: drop old versions (diff)
downloadgentoo-d0f1aa52f380ac736b5fc95cf885fb900f198e02.tar.gz
gentoo-d0f1aa52f380ac736b5fc95cf885fb900f198e02.tar.bz2
gentoo-d0f1aa52f380ac736b5fc95cf885fb900f198e02.zip
dev-libs/gmp: sync GMPABI handling across current versions #563886
No functional changes here really -- just make the ebuilds we want to keep in the tree act the same.
Diffstat (limited to 'dev-libs/gmp/gmp-4.3.2-r1.ebuild')
-rw-r--r--dev-libs/gmp/gmp-4.3.2-r1.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/dev-libs/gmp/gmp-4.3.2-r1.ebuild b/dev-libs/gmp/gmp-4.3.2-r1.ebuild
index c42ae5adf5f9..94a25632690c 100644
--- a/dev-libs/gmp/gmp-4.3.2-r1.ebuild
+++ b/dev-libs/gmp/gmp-4.3.2-r1.ebuild
@@ -22,29 +22,35 @@ RDEPEND=""
src_prepare() {
epatch "${FILESDIR}"/${PN}-4.1.4-noexecstack.patch
- epatch "${FILESDIR}"/${PN}-4.3.2-ABI-multilib.patch
epatch "${FILESDIR}"/${PN}-4.2.1-s390.diff
- sed -i -e 's:ABI = @ABI@:GMPABI = @GMPABI@:' \
- Makefile.in */Makefile.in */*/Makefile.in
-
# note: we cannot run autotools here as gcc depends on this package
elibtoolize
+
+ # GMP uses the "ABI" env var during configure as does Gentoo (econf).
+ # So, to avoid patching the source constantly, wrap things up.
+ mv configure configure.wrapped || die
+ cat <<-\EOF > configure
+ #!/bin/sh
+ exec env ABI="${GMPABI}" "$0.wrapped" "$@"
+ EOF
+ chmod a+rx configure
}
src_configure() {
# Because of our 32-bit userland, 1.0 is the only HPPA ABI that works
# http://gmplib.org/manual/ABI-and-ISA.html#ABI-and-ISA (bug #344613)
if [[ ${CHOST} == hppa2.0-* ]] ; then
- export GMPABI="1.0"
+ GMPABI="1.0"
fi
# ABI mappings (needs all architectures supported)
case ${ABI} in
- 32|x86) export GMPABI=32;;
- 64|amd64|n64) export GMPABI=64;;
- o32|n32) export GMPABI=${ABI};;
+ 32|x86) GMPABI=32;;
+ 64|amd64|n64) GMPABI=64;;
+ [onx]32) GMPABI=${ABI};;
esac
+ export GMPABI
tc-export CC
econf \