summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-26 10:15:53 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-26 10:29:42 +0200
commit41e8f19fc798420d0eb8d3c794f777aa3f19e5be (patch)
tree55725270b3b086f1adbf924e9c8d08d012386049 /dev-libs/gom
parentdev-libs/gom: limit glib max ver due to issues fixed only in gom-0.4 (diff)
downloadgentoo-41e8f19fc798420d0eb8d3c794f777aa3f19e5be.tar.gz
gentoo-41e8f19fc798420d0eb8d3c794f777aa3f19e5be.tar.bz2
gentoo-41e8f19fc798420d0eb8d3c794f777aa3f19e5be.zip
dev-libs/gom: bump to 0.4, improve python handling, py3.8
* Fix for gdk-pixbuf being test-only dep * Add python-3.8 support; should be fine, as it's just simple gi overrides * Handle python gobject-introspection overrides manually to avoid building the whole source tree up to 3 times. The build system way is completely broken for us as well with upstream changes in 0.4 and we'd need to pass the overrides install path manually anyhow (upstream changes make it ignore python3.6 being in /usr/lib64 and python3.7+ being in /usr/lib properly) * python isn't needed without introspection; take the chance to also add a IUSE=python for this, as we handle it manually anyways and don't need upstream support anymore Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/gom')
-rw-r--r--dev-libs/gom/Manifest1
-rw-r--r--dev-libs/gom/gom-0.4.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/gom/Manifest b/dev-libs/gom/Manifest
index e44cf06de932..8e2c6b844aab 100644
--- a/dev-libs/gom/Manifest
+++ b/dev-libs/gom/Manifest
@@ -1,2 +1,3 @@
DIST gom-0.3.2.tar.xz 410300 BLAKE2B c0c79c1c3f8a28a0ee992fa4c316538eb87ec26c77def353e8b2038e32f30f9daed433c6d6f6c81069e05e46a980f7d944c955182d973d42f3bd84a341c5a34d SHA512 a7bfb263e5ff6f89768d8fcbdcc949d4ec9b82ecbb80952becd357a3d5781a60e52a327e865e39e46d542b2a2c5e5c861e5302d7ae3c3a2258d3c3f698263675
DIST gom-0.3.3.tar.xz 101580 BLAKE2B 08e0abb9eaf23ba3bbbca54289ebaa695af705e65b9b612f125e72c62f337baec899d16e657d3de51baeb4ffb79b583716a01d74067e256d59e1dcb63723273e SHA512 152924e704c92f39c493a8becc73fac1f7fe396f4f9e7c154dccec2b4413476821e43abf3c108cc1304de471e61f56c265f124710379ad8568b68f8902064e03
+DIST gom-0.4.tar.xz 102744 BLAKE2B 8116ac388a56e85effbb37c3d5ea5036f6de2f4ad7ee8fe119bd058e1ac3e293eab612a739cdba7467202bc9e258f7cd65b1f116e146577d3a103fc03afba37f SHA512 d847928ce09c53a3f64777c313cb843052e5e001873f29d3f7acf02772cadf0e4b133fb0137aa0463b4ff95dd54810bde87062d8e396ff4fc6d142ba59c8e9c8
diff --git a/dev-libs/gom/gom-0.4.ebuild b/dev-libs/gom/gom-0.4.ebuild
new file mode 100644
index 000000000000..7b2f1c4142ba
--- /dev/null
+++ b/dev-libs/gom/gom-0.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome.org gnome2-utils meson python-r1
+
+DESCRIPTION="GObject to SQLite object mapper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection python test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-db/sqlite-3.7:3
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.16:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ gtk-doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig
+ test? ( x11-libs/gdk-pixbuf:2 )
+"
+
+src_prepare() {
+ default
+ sed -i -e '/subdir.*python/d' bindings/meson.build || die
+ # drop test building and deps if not enabled
+ if ! use test; then
+ sed -i -e '/gdkpixbuf_dep/d' meson.build || die
+ sed -i -e '/subdir(.*tests.*)/d' meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ docinto examples
+ dodoc examples/*.py
+
+ meson_src_install
+
+ if use python; then
+ python_foreach_impl python_domodule bindings/python/gi
+ fi
+}