summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/gtx/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/gtx/files')
-rw-r--r--dev-libs/gtx/files/gtx-0.2.2-debug.patch40
-rw-r--r--dev-libs/gtx/files/gtx-0.2.2-docdir.patch16
-rw-r--r--dev-libs/gtx/files/gtx-0.2.2-glib.h.patch15
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/gtx/files/gtx-0.2.2-debug.patch b/dev-libs/gtx/files/gtx-0.2.2-debug.patch
new file mode 100644
index 000000000000..73f6dfaaad2e
--- /dev/null
+++ b/dev-libs/gtx/files/gtx-0.2.2-debug.patch
@@ -0,0 +1,40 @@
+ Makefile.am | 3 +--
+ examples/Makefile.am | 5 ++---
+ src/Makefile.am | 3 +--
+ 3 files changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index e6bba05..67274c1 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -8,8 +8,7 @@ noinst_PROGRAMS = \
+ command
+
+ AM_CFLAGS =\
+- -Wall \
+- -g
++ -Wall
+
+ simple_SOURCES = \
+ simple.c
+@@ -30,4 +29,4 @@ command_SOURCES = \
+
+ command_LDADD = \
+ $(GTX_LIBS) \
+- $(top_builddir)/src/libgtx.la
+\ No newline at end of file
++ $(top_builddir)/src/libgtx.la
+diff --git a/src/Makefile.am b/src/Makefile.am
+index f5f873e..a40d772 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -4,8 +4,7 @@ INCLUDES = \
+ $(GTX_CFLAGS)
+
+ AM_CFLAGS =\
+- -Wall \
+- -g
++ -Wall
+
+ #
+ # Headers to be installed
diff --git a/dev-libs/gtx/files/gtx-0.2.2-docdir.patch b/dev-libs/gtx/files/gtx-0.2.2-docdir.patch
new file mode 100644
index 000000000000..e6f9a196f9f5
--- /dev/null
+++ b/dev-libs/gtx/files/gtx-0.2.2-docdir.patch
@@ -0,0 +1,16 @@
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index aa401dc..4d99442 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,7 +5,7 @@ SUBDIRS = \
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = gtx.pc
+
+-gtxdocdir = ${prefix}/doc/gtx
++gtxdocdir = ${docdir}
+
+ gtxdoc_DATA = \
+ README \
diff --git a/dev-libs/gtx/files/gtx-0.2.2-glib.h.patch b/dev-libs/gtx/files/gtx-0.2.2-glib.h.patch
new file mode 100644
index 000000000000..0efab61e9b1f
--- /dev/null
+++ b/dev-libs/gtx/files/gtx-0.2.2-glib.h.patch
@@ -0,0 +1,15 @@
+ src/gtx.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/gtx.h b/src/gtx.h
+index 57bee60..ab128b0 100644
+--- a/src/gtx.h
++++ b/src/gtx.h
+@@ -24,7 +24,6 @@
+ #define __GTX_H__
+
+ #include <glib.h>
+-#include <glib/gtestutils.h>
+ #include <glib-object.h>
+
+ G_BEGIN_DECLS