summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-08-20 16:05:57 +0100
committerMarek Szuba <marecki@gentoo.org>2019-08-20 16:14:35 +0100
commit02b7fd5c0c4a9334e942f6b05ac71bcf72a3b6df (patch)
tree4621ec5beac9b0d0796ae459d32a38d7f4b0910c /dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.99.ebuild
parentnet-misc/ntpclient: fix compilation with >=linux-headers-5.2 (diff)
downloadgentoo-02b7fd5c0c4a9334e942f6b05ac71bcf72a3b6df.tar.gz
gentoo-02b7fd5c0c4a9334e942f6b05ac71bcf72a3b6df.tar.bz2
gentoo-02b7fd5c0c4a9334e942f6b05ac71bcf72a3b6df.zip
dev-libs/hsa-ext-rocr: new package
Required for the time being by dev-libs/rocm-opencl-runtime in order to enable OpenCL image support. The relevant code will eventually be open-sourced but so far upstream hasn't provided any timeline for it. There is no licence file in the upstream package, that said the libraries it contains used to be distributed as part of the AMDGPU-Pro stack so it is a safe bet that the standalone package is covered by the same EULA as for dev-libs/amdgpu-pro-opencl. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.99.ebuild')
-rw-r--r--dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.99.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.99.ebuild b/dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.99.ebuild
new file mode 100644
index 000000000000..7d91362d6a00
--- /dev/null
+++ b/dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.99.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+MY_PV=$(ver_rs 3 '-')
+
+DESCRIPTION="Proprietary image-support library for Radeon Open Compute"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm#closed-source-components"
+SRC_URI="http://repo.radeon.com/rocm/apt/debian/pool/main/h/${PN}-dev/${PN}-dev_${MY_PV}-g835b876_amd64.deb"
+
+LICENSE="AMD-GPU-PRO-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="-deprecated"
+
+RESTRICT="mirror fetch strip"
+
+QA_PREBUILT="/opt/${PN}/lib*/*"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Please download the package"
+ einfo
+ einfo " ${SRC_URI}"
+ einfo
+ einfo "and place into your distfiles directory."
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ local destdir="/opt/${PN}"
+ local soversion=$(ver_cut 1-3)
+ local somajor=$(ver_cut 1)
+
+ local solibs_to_install=( "libhsa-ext-image64.so" )
+ if use deprecated; then
+ solibs_to_install+=( "libhsa-runtime-tools64.so" )
+ fi
+
+ into "${destdir}"
+ for solib in ${solibs_to_install[@]}; do
+ dolib.so "opt/rocm/hsa/lib/${solib}.${soversion}"
+ dosym "${EPREFIX}${destdir}/$(get_libdir)/${solib}.${soversion}" "${EPREFIX}usr/$(get_libdir)/${solib}.${soversion}"
+ dosym "${solib}.${soversion}" "${EPREFIX}usr/$(get_libdir)/${solib}.${somajor}"
+ done
+}