summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-06 14:17:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-06 14:22:21 +0100
commit0827ad3ca8fde9cb5fa06a65e0974dc527b13097 (patch)
tree786e4a66d13aa82a9586393bc59f681967fb0a22 /dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
parentdev-python/bitstring: amd64 stable (diff)
downloadgentoo-0827ad3ca8fde9cb5fa06a65e0974dc527b13097.tar.gz
gentoo-0827ad3ca8fde9cb5fa06a65e0974dc527b13097.tar.bz2
gentoo-0827ad3ca8fde9cb5fa06a65e0974dc527b13097.zip
dev-libs/icu-le-hb: Initial commit.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild')
-rw-r--r--dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild b/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
new file mode 100644
index 000000000000..ea8ab465cde4
--- /dev/null
+++ b/dev-libs/icu-le-hb/icu-le-hb-1.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="ICU Layout Engine API on top of HarfBuzz shaping library"
+HOMEPAGE="http://www.harfbuzz.org https://github.com/behdad/icu-le-hb"
+SRC_URI="https://github.com/behdad/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="icu"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/harfbuzz
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/icu
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf
+}