summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <floss@bsd.ac>2021-06-17 19:49:23 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-17 19:49:23 +0200
commitca40f30da5b003bb6ca24460109f2066fb8035be (patch)
tree336cf4003ec73bf033d01d2245fe89efbc8805e1 /dev-libs/igraph/igraph-0.9.4.ebuild
parentRevert "sys-apps/portage: 3.0.20-r2 revbump" (diff)
downloadgentoo-ca40f30da5b003bb6ca24460109f2066fb8035be.tar.gz
gentoo-ca40f30da5b003bb6ca24460109f2066fb8035be.tar.bz2
gentoo-ca40f30da5b003bb6ca24460109f2066fb8035be.zip
dev-libs/igraph: version bump to 0.9.4
Closes: https://github.com/gentoo/gentoo/pull/21283 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/igraph/igraph-0.9.4.ebuild')
-rw-r--r--dev-libs/igraph/igraph-0.9.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/igraph/igraph-0.9.4.ebuild b/dev-libs/igraph/igraph-0.9.4.ebuild
new file mode 100644
index 000000000000..7d9cab598422
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.9.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://www.igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-libs/cxsparse
+ sci-mathematics/glpk:=
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-broken-tests.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DIGRAPH_GLPK_SUPPORT=ON
+ -DIGRAPH_GRAPHML_SUPPORT=ON
+ -DIGRAPH_USE_INTERNAL_ARPACK=OFF
+ -DIGRAPH_USE_INTERNAL_BLAS=OFF
+ -DIGRAPH_USE_INTERNAL_CXSPARSE=OFF
+ -DIGRAPH_USE_INTERNAL_GLPK=OFF
+ -DIGRAPH_USE_INTERNAL_GMP=OFF
+ -DIGRAPH_USE_INTERNAL_LAPACK=OFF
+ -DIGRAPH_ENABLE_TLS=$(usex threads)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}