summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-11-14 23:47:13 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 23:47:13 +0100
commit558aa2b1e30d598d3d5f89ab77189fbfe03b2414 (patch)
tree3c227262d9c022e9a0b9e389a4fc31f797e536d3 /dev-libs/igraph
parentapp-crypt/signify: version bump to 30 (diff)
downloadgentoo-558aa2b1e30d598d3d5f89ab77189fbfe03b2414.tar.gz
gentoo-558aa2b1e30d598d3d5f89ab77189fbfe03b2414.tar.bz2
gentoo-558aa2b1e30d598d3d5f89ab77189fbfe03b2414.zip
dev-libs/igraph: version bump to 0.8.3
Closes: https://github.com/gentoo/gentoo/pull/17749 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/Manifest1
-rw-r--r--dev-libs/igraph/igraph-0.8.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index f2dcaf5efb1c..bb647bf154d5 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1,2 +1,3 @@
DIST igraph-0.7.1.tar.gz 2967134 BLAKE2B 27f0a2f51e561a3ea2e2e6d31853fe10ffd66f9f67603d77f2c0449a4c2bcd4d45c98516b526fb0f23a871ebe3db1fcf0c691551714d044124778faa147bd30f SHA512 ac7d7e3fbc6d27ae69079224881ca03db2c7e0b50d016706f3e167c614e2c9332c675d2fcd3cde12874e13a8fc402d42222308c6195afadee15152cec93f94dd
DIST igraph-0.8.2.tar.gz 3625308 BLAKE2B b3be5a28b6507c98c88a96c4a14e6b9c45645985f5b16aaae0739412a5f26a1ccdbda3180fac5d12525b4da2f5fc3d6caad3928cd1306b151b89104bbbb5f6e8 SHA512 e1035ed22541c7d253c201da5d2f8c5ceb154a6bf4be1b41981a02d6bbe72038647bf011432e2446307e615c27aa8079d4ef2c4447c2eba3764788e26e8f790b
+DIST igraph-0.8.3.tar.gz 3636192 BLAKE2B 1a6636a074182fc859d7c2982546668b221be8a71b9a8a60404764684b7488a41450cedb75f89558f1ffe6f6dbef298057b5294495f2e7992768f5fd4e40fbd9 SHA512 a25126fd5ee7cf823b6728d02d38c8d13c8561e9f6e10372faef15e98f4381c118f3dd9f308d003d7d18ca501e7055b838711a2a62e00afba32ca929c8d765f1
diff --git a/dev-libs/igraph/igraph-0.8.3.ebuild b/dev-libs/igraph/igraph-0.8.3.ebuild
new file mode 100644
index 000000000000..186bd9a51133
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.8.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://www.igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-libs/cxsparse
+ sci-mathematics/glpk:=
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.8.2-unbundle.patch )
+
+src_prepare() {
+ default
+ rm -r src/lapack optional/glpk src/cs || die
+ eautoreconf
+}
+
+src_configure() {
+ # even with --with-external-f2c
+ # we don't need f2c as none of
+ # arpack lapack blas
+ # are internal
+ tc-export PKG_CONFIG
+ econf \
+ $(use_enable debug) \
+ --enable-gmp \
+ --disable-static \
+ --disable-tls \
+ --with-external-arpack \
+ --with-external-blas \
+ --with-external-lapack \
+ --with-external-f2c \
+ --with-external-glpk
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}