summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-02-26 18:52:45 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-26 18:52:45 +0100
commit79031ffe022736ffab005240ae581035d89635ed (patch)
treea7728014cfccb3c0504a24bf5a0d7be78ac7aff0 /dev-libs/igraph
parentnet-wireless/unifi: bump to 6.1.61 (diff)
downloadgentoo-79031ffe022736ffab005240ae581035d89635ed.tar.gz
gentoo-79031ffe022736ffab005240ae581035d89635ed.tar.bz2
gentoo-79031ffe022736ffab005240ae581035d89635ed.zip
dev-libs/igraph: version bump to 0.9.0
* moves to cmake based build system Closes: https://github.com/gentoo/gentoo/pull/19659 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/Manifest1
-rw-r--r--dev-libs/igraph/files/igraph-0.9.0-cmakedirs.patch13
-rw-r--r--dev-libs/igraph/igraph-0.9.0.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index 862a2b7315f0..91e5201f303f 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1,2 +1,3 @@
DIST igraph-0.8.3.tar.gz 3636192 BLAKE2B 1a6636a074182fc859d7c2982546668b221be8a71b9a8a60404764684b7488a41450cedb75f89558f1ffe6f6dbef298057b5294495f2e7992768f5fd4e40fbd9 SHA512 a25126fd5ee7cf823b6728d02d38c8d13c8561e9f6e10372faef15e98f4381c118f3dd9f308d003d7d18ca501e7055b838711a2a62e00afba32ca929c8d765f1
DIST igraph-0.8.5.tar.gz 3303252 BLAKE2B 9aa920e39a1ef76376eb9a88b6d24e2d051aa22807d4e9bbac49fd1708c59f821d2d4ec55dc96a89de84dfc3ca394e3de9f60704b7f3880a40128863b209d0d6 SHA512 eeb7a21b3a0551e47c178e568811a415e39afb2cc99be39905a15d667fa59564e83979111e1ea5d93636d5b0c7dcbed18728f03aa7ee4d83f96c45af52de8370
+DIST igraph-0.9.0.tar.gz 3752584 BLAKE2B ab8724de1fb57fda1250a9a3e1958609004731f72d38c225c23a94b7ad39af8af7a269bb9e9a2cae28b5d4038acbb0fb4f12bc90831340f59cdafa75f4b7c264 SHA512 ee6ddda3ebb9fb01029a3efbbab2329516d42ecb3030c57e7a78c8d7f28b76650fb4f3245e993cbef6161de6f6a1e0a4f5ba2533cbd8271df72554561b4f407f
diff --git a/dev-libs/igraph/files/igraph-0.9.0-cmakedirs.patch b/dev-libs/igraph/files/igraph-0.9.0-cmakedirs.patch
new file mode 100644
index 000000000000..a7682d41e0a4
--- /dev/null
+++ b/dev-libs/igraph/files/igraph-0.9.0-cmakedirs.patch
@@ -0,0 +1,13 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -440,8 +440,8 @@ generate_export_header(igraph
+ include(GNUInstallDirs)
+ install(
+ TARGETS igraph
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ )
+ install(
+ DIRECTORY ${CMAKE_SOURCE_DIR}/include/
diff --git a/dev-libs/igraph/igraph-0.9.0.ebuild b/dev-libs/igraph/igraph-0.9.0.ebuild
new file mode 100644
index 000000000000..d825b06fa454
--- /dev/null
+++ b/dev-libs/igraph/igraph-0.9.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Creating and manipulating undirected and directed graphs"
+HOMEPAGE="http://www.igraph.org/"
+SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2
+ sci-libs/arpack
+ sci-libs/cxsparse
+ sci-mathematics/glpk:=
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.0-cmakedirs.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_CCACHE=OFF
+ -DIGRAPH_GLPK_SUPPORT=ON
+ -DIGRAPH_GRAPHML_SUPPORT=ON
+ -DIGRAPH_USE_INTERNAL_ARPACK=OFF
+ -DIGRAPH_USE_INTERNAL_BLAS=OFF
+ -DIGRAPH_USE_INTERNAL_CXSPARSE=OFF
+ -DIGRAPH_USE_INTERNAL_GLPK=OFF
+ -DIGRAPH_USE_INTERNAL_GMP=OFF
+ -DIGRAPH_USE_INTERNAL_LAPACK=OFF
+ -DIGRAPH_ENABLE_TLS=$(usex threads)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}