summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-11 00:16:44 -0400
committerSam James <sam@gentoo.org>2024-03-11 14:22:51 +0000
commitcccba67944b52d8d48beb95a39e653ecbbf5471f (patch)
treece1e069a61236fa69c9dd4148a5857b9f7deb90f /dev-libs/igraph
parentdev-libs/igraph: add 0.10.10 (diff)
downloadgentoo-cccba67944b52d8d48beb95a39e653ecbbf5471f.tar.gz
gentoo-cccba67944b52d8d48beb95a39e653ecbbf5471f.tar.bz2
gentoo-cccba67944b52d8d48beb95a39e653ecbbf5471f.zip
dev-libs/igraph: mark as LTO-unsafe, strict-aliasing unsafe
Only in 0.10.4, as it is fixed and backported into the ~arch version. Bug: https://bugs.gentoo.org/924864 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/igraph-0.10.4-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/igraph/igraph-0.10.4-r1.ebuild b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
index 0020face7f80..fd9d1d6f77ec 100644
--- a/dev-libs/igraph/igraph-0.10.4-r1.ebuild
+++ b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Creating and manipulating undirected and directed graphs"
HOMEPAGE="https://igraph.org/"
@@ -27,6 +27,12 @@ RDEPEND="
DEPEND="${RDEPEND}"
src_configure() {
+ # -Werror=strict-aliasing
+ #
+ # Fixed in upstream git master.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DUSE_CCACHE=OFF
-DIGRAPH_GLPK_SUPPORT=ON