summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-24 23:36:15 +0000
committerSam James <sam@gentoo.org>2022-03-24 23:57:03 +0000
commit67b1e3883fdbd708bbb4c705459fc48e031a2e58 (patch)
tree88bd81613c0c8117182dc49059db580de205178b /dev-libs/inih
parentnet-analyzer/nfdump: add additional autoconf 2.69+ patches (diff)
downloadgentoo-67b1e3883fdbd708bbb4c705459fc48e031a2e58.tar.gz
gentoo-67b1e3883fdbd708bbb4c705459fc48e031a2e58.tar.bz2
gentoo-67b1e3883fdbd708bbb4c705459fc48e031a2e58.zip
dev-libs/inih: add 54
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest1
-rw-r--r--dev-libs/inih/files/inih-54-set-version.patch20
-rw-r--r--dev-libs/inih/inih-54.ebuild35
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
index e19e85d2c827..1bb3e441dac8 100644
--- a/dev-libs/inih/Manifest
+++ b/dev-libs/inih/Manifest
@@ -1 +1,2 @@
DIST inih-53.tar.gz 16984 BLAKE2B 1242e6273c9dd9a11ea026a3495a487b2aa72d8e01f34304d8568c88897ae9c9bb425246f992dc16f4dc2210ec14c597d0ef595cec84ff98a5d6101ee5a643b9 SHA512 99bc40c294b521e9973184bfb30d60c129735991f33b387b3d023827a34672b0489eadf91e38895ea725168dbc7b27bb02c1975debe7573b4b209d0e947b2100
+DIST inih-54.tar.gz 18217 BLAKE2B 53c809fd8bd0a1998eca6dd4ac1d1fb88960c04e1cf4e1c2b24c4b7214c210d15915da1efdec15248010ab52b26f61ffe8d7302fed4643246cf0b6b65a5efb80 SHA512 47952d5ce86dd02b61960bf76dd1290272b62ab371b2ed7d54bd9f42de47cf2b19d9cfe8ef8e67d0e80729f8a7d9b7a97ad0b3fbc8d02199351368d8cafb62fa
diff --git a/dev-libs/inih/files/inih-54-set-version.patch b/dev-libs/inih/files/inih-54-set-version.patch
new file mode 100644
index 000000000000..b9dba1ffb0be
--- /dev/null
+++ b/dev-libs/inih/files/inih-54-set-version.patch
@@ -0,0 +1,20 @@
+https://github.com/benhoyt/inih/pull/135
+
+From 690fd8cb5a1c7db67e78b9e2543ff5a9fc733ce3 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 24 Mar 2022 23:32:46 +0000
+Subject: [PATCH] meson.build: define version
+
+Otherwise, the installed .pc file contains "Version: undefined".
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/meson.build
++++ b/meson.build
+@@ -1,6 +1,7 @@
+ project('inih',
+ ['c'],
+ license : 'BSD-3-Clause',
++ version : '54',
+ )
+
+ #### options ####
diff --git a/dev-libs/inih/inih-54.ebuild b/dev-libs/inih/inih-54.ebuild
new file mode 100644
index 000000000000..dc8fa977393a
--- /dev/null
+++ b/dev-libs/inih/inih-54.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Tests not wired up to meson and don't seem to be intended for downstream use yet
+# e.g. hardcoding gcc, just a shell script
+
+inherit meson-multilib
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+S="${WORKDIR}/inih-r${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-set-version.patch
+)
+
+DOCS=( README.md )
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}