summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/intel-common/intel-common-14.0.3.174.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/intel-common/intel-common-14.0.3.174.ebuild')
-rw-r--r--dev-libs/intel-common/intel-common-14.0.3.174.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/intel-common/intel-common-14.0.3.174.ebuild b/dev-libs/intel-common/intel-common-14.0.3.174.ebuild
new file mode 100644
index 000000000000..3424003e44c8
--- /dev/null
+++ b/dev-libs/intel-common/intel-common-14.0.3.174.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=4220
+INTEL_DPV=2013_sp1_update3
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Common libraries and utilities needed for Intel compilers and libraries"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-compilers/"
+
+IUSE="+compiler"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+CHECKREQS_DISK_BUILD=375M
+
+pkg_setup() {
+ einfo ${INTEL_SDP_EDIR}
+ INTEL_BIN_RPMS="openmp openmp-devel"
+ INTEL_DAT_RPMS="compilerpro-common"
+ if use compiler; then
+ INTEL_BIN_RPMS+=" compilerpro-devel sourcechecker-devel"
+ INTEL_DAT_RPMS+=" compilerpro-vars sourcechecker-common"
+ fi
+ intel-sdp_pkg_setup
+}
+
+src_install() {
+ intel-sdp_src_install
+ local path rootpath ldpath arch fenv=35intelsdp
+ cat > ${fenv} <<-EOF
+ NLSPATH=${INTEL_SDP_EDIR}/lib/locale/en_US/%N
+ INTEL_LICENSE_FILE="${INTEL_SDP_EDIR}"/licenses:"${EPREFIX}/opt/intel/license"
+ EOF
+ for arch in ${INTEL_ARCH}; do
+ path=${path}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ rootpath=${rootpath}:${INTEL_SDP_EDIR}/bin/${arch}:${INTEL_SDP_EDIR}/mpirt/bin/${arch}
+ ldpath=${ldpath}:${INTEL_SDP_EDIR}/compiler/lib/${arch}:${INTEL_SDP_EDIR}/mpirt/lib/${arch}
+ done
+ cat >> ${fenv} <<-EOF
+ PATH=${path#:}
+ ROOTPATH=${rootpath#:}
+ LDPATH=${ldpath#:}
+ EOF
+
+ doenvd ${fenv}
+
+ cat >> "${T}"/40-${PN} <<- EOF
+ SEARCH_DIRS_MASK="${INTEL_SDP_EDIR}"
+ EOF
+ insinto /etc/revdep-rebuild/
+ doins "${T}"/40-${PN}
+}