summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-26 08:12:21 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-26 12:55:36 +0200
commit58b64ae193409550db08bc17dc160b3085ce05a9 (patch)
tree6002454d63a4de5cf56de38ca868fd0ba79b2354 /dev-libs/jsoncpp
parentapp-office/libreoffice: 6.4.6.2-r2 revbump fixing uno.py installation (diff)
downloadgentoo-58b64ae193409550db08bc17dc160b3085ce05a9.tar.gz
gentoo-58b64ae193409550db08bc17dc160b3085ce05a9.tar.bz2
gentoo-58b64ae193409550db08bc17dc160b3085ce05a9.zip
dev-libs/jsoncpp: Bump to 1.9.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/jsoncpp')
-rw-r--r--dev-libs/jsoncpp/Manifest1
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/Manifest b/dev-libs/jsoncpp/Manifest
index 791c5258436d..b73bf186ae7b 100644
--- a/dev-libs/jsoncpp/Manifest
+++ b/dev-libs/jsoncpp/Manifest
@@ -1 +1,2 @@
DIST jsoncpp-1.9.3.tar.gz 212922 BLAKE2B 6f89762e899ffe127705a30c1fe86f458d62fa05b8dbde6c465c73b6855d3945f3d739ff0c26e1a6326a211c946277908684ace9363df72ba0f460f66b3e3fd8 SHA512 f1c035d54ed952d8d4e41acab5c3ecf6aa445f348f98aeac2e7c89555ec2f6421d727b3bc4c2f54176afce137c545b20d886562901953ec091f91890e91e8559
+DIST jsoncpp-1.9.4.tar.gz 214057 BLAKE2B 9a8c52e5d0b78f1593c93bc40f48d3789b031ba0da519c99cce17f1f6e104b24e0ffe88138c25da6dfa250586aeb9e98d00fbf74d9fb9309b29a6d4f17762263 SHA512 adfd4afbdf6b79bd37edcf0e248f07864994f1c4bcb7431f3b44102490ce467f72381908066655fa486dec12f467af0a11f42f859bbf719895974c7339db7d22
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild
new file mode 100644
index 000000000000..1d7f0a221b2b
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.9.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="
+ https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/24"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ --includedir include/jsoncpp
+ -Dtests=$(usex test true false)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ if use doc; then
+ echo "${PV}" > version || die
+ "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
+ HTML_DOCS=( dist/doxygen/jsoncpp*/. )
+ fi
+}