summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-07-17 17:11:10 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-07-17 17:42:32 +0300
commit9465694693f75a0b47e92eb8a46908de16903b2e (patch)
tree2bc4e609d97169d0ec4978047bdddb4e3176466b /dev-libs/jthread/jthread-1.3.3.ebuild
parentmail-mta/postfix: bump to 3.3_pre20170716 (diff)
downloadgentoo-9465694693f75a0b47e92eb8a46908de16903b2e.tar.gz
gentoo-9465694693f75a0b47e92eb8a46908de16903b2e.tar.bz2
gentoo-9465694693f75a0b47e92eb8a46908de16903b2e.zip
dev-libs/jthread: version bump, add multilib support
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs/jthread/jthread-1.3.3.ebuild')
-rw-r--r--dev-libs/jthread/jthread-1.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/jthread/jthread-1.3.3.ebuild b/dev-libs/jthread/jthread-1.3.3.ebuild
new file mode 100644
index 000000000000..e854d07537d5
--- /dev/null
+++ b/dev-libs/jthread/jthread-1.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms"
+HOMEPAGE="http://research.edm.uhasselt.be/jori/page/CS/Jthread.html"
+SRC_URI="http://research.edm.uhasselt.be/jori/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="static-libs"
+
+DOCS=( ChangeLog README.md doc/manual.tex )
+
+src_prepare() {
+ # do not build static library, if it is not requested
+ if ! use static-libs; then
+ sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
+ fi
+ cmake-utils_src_prepare
+}