summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 12:41:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:48:30 +0200
commit01d4d2ac43479eb7eba5b8f967679263175dcd5c (patch)
tree97b9c5cbf1db49f3430a482c849c508b190dc064 /dev-libs/kopeninghours
parentnet-p2p/ktorrent: 21.08.1 version bump (diff)
downloadgentoo-01d4d2ac43479eb7eba5b8f967679263175dcd5c.tar.gz
gentoo-01d4d2ac43479eb7eba5b8f967679263175dcd5c.tar.bz2
gentoo-01d4d2ac43479eb7eba5b8f967679263175dcd5c.zip
dev-libs/kopeninghours: 21.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-21.08.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 77a0984e8e17..50fe4047d42f 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1,2 +1,3 @@
DIST kopeninghours-21.04.3.tar.xz 63212 BLAKE2B 8f16566559b529ca44aaa0cb6b8267cc4d253c82e336d210cd240191ea5b60e029d6acd914053707c010bf94628cfb43e9fa0cc5625f275808426f75ecaf8e6a SHA512 d368cdbfe9dfcd82a847b932ddd244bdabfabdf1d44dbf6fb371f3af294f538d77d9f955fdbf1d9a34a2f18e84e649ac32e4b6e296cd7a8cc84d0238ca89bd6d
DIST kopeninghours-21.08.0.tar.xz 65696 BLAKE2B e6fe12eea2f3cab18e07d7c17277a932ad3f57e897e727b61d4740aea87699669bd04becfe9943dd72f562d50141abed30c6342ac7728e0d0b386075b0ac6309 SHA512 529c53ac47eaa629ad0927b7ab3b29c3d89ec8313434ff59c123d6eae62caf6bde1c243045b56ab19ae2b0b8c6bf021baf20f89a14ce82e2ff759642709f3bfe
+DIST kopeninghours-21.08.1.tar.xz 65660 BLAKE2B 9647a1178904f47d6856f141e4d5823067249c0ce9ded65796c8c12448830db06d07e6d918534808930bf7e35cbd67016a5d53cc375da4c12621f2b3249e32b4 SHA512 944682e064c48d0b1e0acdeb4b0f0bb9fd7375af2d8ae82c7aa03d261441d3b4cfbd059c33ecc266d5ed07ae5dab237ed40b8f7187d26ac2da49e05cbb21199d
diff --git a/dev-libs/kopeninghours/kopeninghours-21.08.1.ebuild b/dev-libs/kopeninghours/kopeninghours-21.08.1.ebuild
new file mode 100644
index 000000000000..bd46d6ad91b3
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-21.08.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+PYTHON_COMPAT=( python3_{8..10} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-21.03.90-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}