summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-12 19:47:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-13 21:54:21 +0200
commit514a47f7700d3ed92fb346c060e2ad1a279aa38e (patch)
tree0491f06ed34867e7fe8727cf4e2f00a4ec50df9b /dev-libs/kopeninghours
parentnet-p2p/ktorrent: 22.04.1 version bump (diff)
downloadgentoo-514a47f7700d3ed92fb346c060e2ad1a279aa38e.tar.gz
gentoo-514a47f7700d3ed92fb346c060e2ad1a279aa38e.tar.bz2
gentoo-514a47f7700d3ed92fb346c060e2ad1a279aa38e.zip
dev-libs/kopeninghours: 22.04.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-22.04.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 29d84ac84369..f5da6d8749ac 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1,2 +1,3 @@
DIST kopeninghours-21.12.3.tar.xz 68916 BLAKE2B d80275c195231ca52e0042149d685224c9ffadd6d341ddce1af6f46df451442e924f282119c91ab004dcabb64b112de559bbbcddc2a91daee5cf9a76b84fb4bb SHA512 42bdbe8172ff5ff89469786f3d544db4a07bc0d1de9a54b8525dc8789d0f4328159ee815c07595463f190073433de567fb2d3496d261daa46aac70354b3da6ae
DIST kopeninghours-22.04.0.tar.xz 69016 BLAKE2B 6e432bb2981b4eb62970fef37390ff871ee51a09e964434f2c43bf89de8ab2568b4843369fa99166fc731937989a155c9f391c2cc32c023f4be56ff886fabc60 SHA512 21bbd64000dec12015a5a2904f414876602a1b7096d6c64f4b327ed4d38d5a38d5058138a422c6fe41f7e205508b753b9d0502b1379d0e8816f1d4929d3fe45c
+DIST kopeninghours-22.04.1.tar.xz 69180 BLAKE2B 97ffbd30a0eb6a2d26aefef6c3bb2d0e81b8319e37eca827649a19d826cb47745b2bea19e881c9445b00d53f48025781865481fcce877ddd68add33690e751d0 SHA512 1dc82a84e85d6a9894235cc4f21a8dd376c1172c934f32355ce4ff93aff1af926d027275badc9f10ac77db251fb407bad8ee0b94d19278db23728d22d342456c
diff --git a/dev-libs/kopeninghours/kopeninghours-22.04.1.ebuild b/dev-libs/kopeninghours/kopeninghours-22.04.1.ebuild
new file mode 100644
index 000000000000..2f0dacc76970
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-22.04.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+QTMIN=5.15.3
+PYTHON_COMPAT=( python3_{8..10} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}