summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-08 13:31:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-08 13:44:09 +0200
commit741bd2d882b56b011c22fc78881e144ad16557bd (patch)
treec5659272aff570c32a5b3fbd168cd45fc4afc12c /dev-libs/kopeninghours
parentnet-p2p/ktorrent: 21.04.3 version bump (diff)
downloadgentoo-741bd2d882b56b011c22fc78881e144ad16557bd.tar.gz
gentoo-741bd2d882b56b011c22fc78881e144ad16557bd.tar.bz2
gentoo-741bd2d882b56b011c22fc78881e144ad16557bd.zip
dev-libs/kopeninghours: 21.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kopeninghours')
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-21.04.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index f3136e74c72e..3d3d7b0a808e 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1 +1,2 @@
DIST kopeninghours-21.04.2.tar.xz 62824 BLAKE2B 1bd346fc46894199fd0f80a5cb35768de4131d1c0daf4594f4500745f8b0e79209fe41308b8e005fa1b0c6424d1776aeece3dd39b065e6ce0159f9a094679df3 SHA512 566550704a1ffe92249a026ffca10ec52514e2460da459df6dbf457065cfab5c9462ff1b9a90aa9c35637121fdff00ac89986764b5c77b519f5ac5c2174faf85
+DIST kopeninghours-21.04.3.tar.xz 63212 BLAKE2B 8f16566559b529ca44aaa0cb6b8267cc4d253c82e336d210cd240191ea5b60e029d6acd914053707c010bf94628cfb43e9fa0cc5625f275808426f75ecaf8e6a SHA512 d368cdbfe9dfcd82a847b932ddd244bdabfabdf1d44dbf6fb371f3af294f538d77d9f955fdbf1d9a34a2f18e84e649ac32e4b6e296cd7a8cc84d0238ca89bd6d
diff --git a/dev-libs/kopeninghours/kopeninghours-21.04.3.ebuild b/dev-libs/kopeninghours/kopeninghours-21.04.3.ebuild
new file mode 100644
index 000000000000..711c6c4bcfd3
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-21.04.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.80.0
+QTMIN=5.15.2
+PYTHON_COMPAT=( python3_{8,9} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-21.03.90-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}