summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-21 16:06:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-21 17:45:10 +0100
commit2bbd49c6468f673f89b5bc13dd842c0f3cb5b160 (patch)
treef48a18c79313f178e454d0bc961f1e6477abee91 /dev-libs/kpeoplevcard
parentapp-editors/okteta: EAPI-8 bump, upstream crash fix (diff)
downloadgentoo-2bbd49c6468f673f89b5bc13dd842c0f3cb5b160.tar.gz
gentoo-2bbd49c6468f673f89b5bc13dd842c0f3cb5b160.tar.bz2
gentoo-2bbd49c6468f673f89b5bc13dd842c0f3cb5b160.zip
dev-libs/kpeoplevcard: EAPI-8 bump, missing DEPEND, upstream fix
Upstream commit 778d03445f41c536f2ca9116ee6acb5f4f01b868 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=423845 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kpeoplevcard')
-rw-r--r--dev-libs/kpeoplevcard/files/kpeoplevcard-0.1-emit-initial-fetch-complete-signal.patch29
-rw-r--r--dev-libs/kpeoplevcard/kpeoplevcard-0.1-r1.ebuild34
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/kpeoplevcard/files/kpeoplevcard-0.1-emit-initial-fetch-complete-signal.patch b/dev-libs/kpeoplevcard/files/kpeoplevcard-0.1-emit-initial-fetch-complete-signal.patch
new file mode 100644
index 000000000000..3f16d9f5b674
--- /dev/null
+++ b/dev-libs/kpeoplevcard/files/kpeoplevcard-0.1-emit-initial-fetch-complete-signal.patch
@@ -0,0 +1,29 @@
+From 778d03445f41c536f2ca9116ee6acb5f4f01b868 Mon Sep 17 00:00:00 2001
+From: Dimitar Petrovski <dimeptr@gmail.com>
+Date: Mon, 6 Jul 2020 18:36:31 +0200
+Subject: [PATCH] Emit the Initial Fetch Complete signal
+
+BUG: 423845
+The plugin does not emit the initialFetchComplete signal which seems
+needed by AllContactsMonitor and PersonsModel does not get initialized
+since it waitd for the signal from all plugins
+---
+ src/kpeoplevcard.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/kpeoplevcard.cpp b/src/kpeoplevcard.cpp
+index bfaf71e..20531f6 100644
+--- a/src/kpeoplevcard.cpp
++++ b/src/kpeoplevcard.cpp
+@@ -153,6 +153,8 @@ KPeopleVCard::KPeopleVCard()
+
+ processDirectory(QFileInfo(*vcardsLocation));
+
++ emitInitialFetchComplete(true);
++
+ connect(m_fs, &KDirWatch::dirty, this, [this](const QString& path) {
+ const QFileInfo fi(path);
+ if (fi.isFile())
+--
+GitLab
+
diff --git a/dev-libs/kpeoplevcard/kpeoplevcard-0.1-r1.ebuild b/dev-libs/kpeoplevcard/kpeoplevcard-0.1-r1.ebuild
new file mode 100644
index 000000000000..3f8700aecede
--- /dev/null
+++ b/dev-libs/kpeoplevcard/kpeoplevcard-0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="pim"
+KFMIN=5.82.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library to expose vcards to KPeople"
+HOMEPAGE="https://invent.kde.org/pim/kpeoplevcard"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kpeople-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-emit-initial-fetch-complete-signal.patch" # KDE-bug 423845
+)