summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-03-18 11:45:20 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-03-18 12:17:33 +1100
commit152f2c90c74f33fe77ebbe8e7cdcb722a1d7f3d9 (patch)
treeff7b3de6ea3add77e975f6234172116d9538ba3f /dev-libs/kproperty/kproperty-3.1.0.ebuild
parentsys-apps/kbd-2.0.4: ppc64 stable, bug 645022 (diff)
downloadgentoo-152f2c90c74f33fe77ebbe8e7cdcb722a1d7f3d9.tar.gz
gentoo-152f2c90c74f33fe77ebbe8e7cdcb722a1d7f3d9.tar.bz2
gentoo-152f2c90c74f33fe77ebbe8e7cdcb722a1d7f3d9.zip
dev-libs/kproperty: version bump 3.1.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/kproperty/kproperty-3.1.0.ebuild')
-rw-r--r--dev-libs/kproperty/kproperty-3.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/kproperty/kproperty-3.1.0.ebuild b/dev-libs/kproperty/kproperty-3.1.0.ebuild
new file mode 100644
index 000000000000..8969dc1eb313
--- /dev/null
+++ b/dev-libs/kproperty/kproperty-3.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Property editing framework with editor widget similar to Qt Designer"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="5/4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}"
+
+# tests require installed headers, bug 636108
+RESTRICT+=" test"