summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 10:12:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 11:12:16 +0200
commitedb7969b3e65769c17c2a4e707c827d02577b6f5 (patch)
treef0a502bfc6895ec1583d714860b96d7cc99f9b33 /dev-libs/kpublictransport
parentdev-libs/kosmindoormap: 23.04.0 version bump (diff)
downloadgentoo-edb7969b3e65769c17c2a4e707c827d02577b6f5.tar.gz
gentoo-edb7969b3e65769c17c2a4e707c827d02577b6f5.tar.bz2
gentoo-edb7969b3e65769c17c2a4e707c827d02577b6f5.zip
dev-libs/kpublictransport: 23.04.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/kpublictransport')
-rw-r--r--dev-libs/kpublictransport/Manifest1
-rw-r--r--dev-libs/kpublictransport/kpublictransport-23.04.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/kpublictransport/Manifest b/dev-libs/kpublictransport/Manifest
index 41a288ee24fc..0caafb2f1d11 100644
--- a/dev-libs/kpublictransport/Manifest
+++ b/dev-libs/kpublictransport/Manifest
@@ -1 +1,2 @@
DIST kpublictransport-22.12.3.tar.xz 490936 BLAKE2B 36e60afed1d0a6f1e45a5fbf21c1495ba40e0a1eb0de12957b6a637229029bfaf662f6d14ff11fc6aa62a79aac7605827edd77c22524cfc8693285b6929bb0c3 SHA512 245db3814daf19a3d63b1932026a73ac488670451976266db6d0102fdf83b8878e3fc6886ab9ea7b2a1cf35607a451c964a6ce8cbad36f03e68d4ef21ed21429
+DIST kpublictransport-23.04.0.tar.xz 533660 BLAKE2B 754ad2f8bd6d404c0476bc0413140499704aaeb6bd5b8e4ae3949c56fa8f5742503d50a6c989bc8377b5ff7431dcd4c8e56749800a0a1c87de5924c17261d2bd SHA512 fba0ffee2ea6873738899105823007a5595f2a436a64cb77bdbb541f6ae902d68571c5fd2c659da67e79ef3b242d0c5527a2924991a4acf80a379db557319d28
diff --git a/dev-libs/kpublictransport/kpublictransport-23.04.0.ebuild b/dev-libs/kpublictransport/kpublictransport-23.04.0.ebuild
new file mode 100644
index 000000000000..07abee9ebd6c
--- /dev/null
+++ b/dev-libs/kpublictransport/kpublictransport-23.04.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=5.104.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Library for accessing public transport timetables and other information"
+HOMEPAGE="https://invent.kde.org/libraries/kpublictransport
+ https://www.volkerkrause.eu/2019/03/02/kpublictransport-introduction.html"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="networkmanager"
+
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ networkmanager? ( >=kde-frameworks/networkmanager-qt-${KFMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ $(cmake_use_find_package networkmanager KF5NetworkManagerQt)
+ )
+ ecm_src_configure
+}