summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-12 02:30:59 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-13 16:13:35 +0100
commit952a26789ea75514dadaab00755fe8d9dab2276d (patch)
tree414132d4a378a42db9530a44b9cc7e5960d2443c /dev-libs/kqoauth/kqoauth-0.98-r2.ebuild
parentapp-admin/logstash-bin: drop old (diff)
downloadgentoo-952a26789ea75514dadaab00755fe8d9dab2276d.tar.gz
gentoo-952a26789ea75514dadaab00755fe8d9dab2276d.tar.bz2
gentoo-952a26789ea75514dadaab00755fe8d9dab2276d.zip
dev-libs/kqoauth: migrate to Qt5
Closes: https://github.com/gentoo/gentoo/pull/3925
Diffstat (limited to 'dev-libs/kqoauth/kqoauth-0.98-r2.ebuild')
-rw-r--r--dev-libs/kqoauth/kqoauth-0.98-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/kqoauth/kqoauth-0.98-r2.ebuild b/dev-libs/kqoauth/kqoauth-0.98-r2.ebuild
new file mode 100644
index 000000000000..336a00211b41
--- /dev/null
+++ b/dev-libs/kqoauth/kqoauth-0.98-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Library for Qt that implements the OAuth 1.0 authentication specification"
+HOMEPAGE="https://github.com/kypeli/kQOAuth"
+SRC_URI="https://github.com/kypeli/kQOAuth/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/kQOAuth-${PV}"
+
+src_prepare() {
+ default
+
+ # prevent tests from beeing built at src_compile
+ sed -i -e '/SUBDIRS/s/ tests//' ${PN}.pro || die "sed on ${PN}.pro failed"
+ # respect libdir
+ sed -e 's:{INSTALL_PREFIX}/lib:[QT_INSTALL_LIBS]:g' -i src/src.pro || die "sed on src.pro failed"
+
+ sed \
+ -e "s/TARGET = kqoauth/TARGET = kqoauth-qt5/g" \
+ -i src/src.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}