summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libappindicator/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libappindicator/files')
-rw-r--r--dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch b/dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch
new file mode 100644
index 000000000000..6a5e15f3c0b1
--- /dev/null
+++ b/dev-libs/libappindicator/files/libappindicator-12.10.0-conditional-py-bindings.patch
@@ -0,0 +1,72 @@
+--- bindings/Makefile.am 2015-07-10 10:04:18.091199191 +0200
++++ bindings/Makefile.am 2015-07-10 10:19:47.047974439 +0200
+@@ -3,8 +3,10 @@
+ vala
+ else
+ SUBDIRS = \
+- python \
+ vala
++if HAS_PYTHON
++SUBDIRS += python
++endif
+ endif
+
+ if HAS_MONO
+--- configure.ac 2015-07-16 13:28:41.007502838 +0200
++++ configure.ac_new 2015-07-16 13:53:18.118602877 +0200
+@@ -188,25 +188,37 @@
+ PYGTK_REQUIRED=2.14.0
+ PYGOBJECT_REQUIRED=0.22
+
+-AM_PATH_PYTHON(2.3.5)
+-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
++AC_ARG_ENABLE([python],
++ AC_HELP_STRING([--enable-python], [Enable python for GTK2 build]),,
++ [enable_python=yes])
+
+-PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
++if test x"$with_gtk" = x"3" ; then
++ enable_python=no
++fi
++
++AM_CONDITIONAL(HAS_PYTHON, test x"${enable_python}" != x"no")
++
++if test x"$enable_python" != x"no" ; then
++ AM_PATH_PYTHON(2.3.5)
++ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
++
++ PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
+ [
+ pygtk-2.0 >= $PYGTK_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ pygobject-2.0 >= $PYGOBJECT_REQUIRED
+ ])
+
+-AC_MSG_CHECKING(for pygtk defs)
+-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
+-AC_SUBST(PYGTK_DEFSDIR)
+-AC_MSG_RESULT($PYGTK_DEFSDIR)
+-
+-AC_MSG_CHECKING(for pygtk codegen)
+-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+-AC_SUBST(PYGTK_CODEGEN)
+-AC_MSG_RESULT($PYGTK_CODEGEN)
++ AC_MSG_CHECKING(for pygtk defs)
++ PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
++ AC_SUBST(PYGTK_DEFSDIR)
++ AC_MSG_RESULT($PYGTK_DEFSDIR)
++
++ AC_MSG_CHECKING(for pygtk codegen)
++ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
++ AC_SUBST(PYGTK_CODEGEN)
++ AC_MSG_RESULT($PYGTK_CODEGEN)
++fi
+
+ #########################
+ # Check if build tests
+@@ -278,4 +290,5 @@
+ Tests: $enable_tests
+ Mono tests: $have_nunit
+ gcov: $use_gcov
++ Python: $enable_python
+ ])