summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-03-05 11:04:50 +0000
committerMatthew Smith <matthew@gentoo.org>2022-03-05 11:53:32 +0000
commit4d7dba0ba925fc5730e4ce148afd77c281fcea57 (patch)
tree4253f4d70e02c7349b60646b71b1526f5202d561 /dev-libs/libarcus
parentnet-libs/courier-authlib: Remove obsolete configure parameter. (diff)
downloadgentoo-4d7dba0ba925fc5730e4ce148afd77c281fcea57.tar.gz
gentoo-4d7dba0ba925fc5730e4ce148afd77c281fcea57.tar.bz2
gentoo-4d7dba0ba925fc5730e4ce148afd77c281fcea57.zip
dev-libs/libarcus: add 4.13.1
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-libs/libarcus')
-rw-r--r--dev-libs/libarcus/Manifest1
-rw-r--r--dev-libs/libarcus/libarcus-4.13.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libarcus/Manifest b/dev-libs/libarcus/Manifest
index ec151c0e8f51..6eca64dd2be0 100644
--- a/dev-libs/libarcus/Manifest
+++ b/dev-libs/libarcus/Manifest
@@ -1,3 +1,4 @@
DIST libarcus-4.12.1.tar.gz 32079 BLAKE2B 0efc45f3ddb4d08f960b2a629b0ad58cad9cbf16e90d75ca4f63706acb3ce8625dbe7c51c9265074f3104b66f23385c41e865fbc603a0b43c848c55a95b1f971 SHA512 0b2f2a0b4c3492725b83f2c8b0bb38a2cba10c27317cedd722b27447f0e36c571f1ae7a796de29cfb30e9827f35449327cc20c21780212fdeb35d05c90c3e2e6
DIST libarcus-4.13.0.tar.gz 32079 BLAKE2B 56ddd99c347936770c5b2a99d337784605a27fda2c8a16e1537b25f5ff4d2ccead20e4992aed6cfba439be73a42dc2785da9681e80bc1a7c0ef0aa3a2c33f630 SHA512 a48ab1cb286c13b817363e113707499f2619724c8d2f7672309f9aad78123a89f60e60e92932d8761af87ec5f868f8c319717457532d45e3f2d8e5c3cc010db5
+DIST libarcus-4.13.1.tar.gz 32077 BLAKE2B 8a75de1ccd0879db817cd67600f83e765e00eed175d73685331ea7f1cde07dabd5c49c9b0f3f039a2a0e6ad7f491fa34de62054494fd9c588e3bb530370b65b7 SHA512 ffb14595f23c47f71082b994eae01471f45e2e9e1ae9a8ad01df577b9445594c30173388beab016a92be9723638ca6e46b5cecddddc6adc97e9d212fc0fa23fa
DIST libarcus-4.9.1.tar.gz 31967 BLAKE2B 2ee827c3f1f592ac1efa7557a2cbfa9cf9fd2d43a7be7fd803f94f7b51c9a03be1078d3df319e1bbe2bc37b6ec3a1c6f16996c4e3b6251dd06f6031dd32ad2a9 SHA512 5124b80647cb0715ad94c5eaaeac797a867319de9a8064b689783fdb28598903a69e3a61393db90f5e0b3d10ee30aed844170cab63dc4b7c70509d5129a17cdd
diff --git a/dev-libs/libarcus/libarcus-4.13.1.ebuild b/dev-libs/libarcus/libarcus-4.13.1.ebuild
new file mode 100644
index 000000000000..119faccb2d4b
--- /dev/null
+++ b/dev-libs/libarcus/libarcus-4.13.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-single-r1
+
+MY_PN="libArcus"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libArcus"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples +python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/protobuf:=
+ $(python_gen_cond_dep '
+ <dev-python/sip-5[${PYTHON_USEDEP}]
+ python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )
+ ')"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.8.0-deprecated-protobuf-calls.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Find SIP for current python version, not the latest installed
+ sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" \
+ CMakeLists.txt cmake/FindSIP.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples ON OFF)
+ -DBUILD_PYTHON=$(usex python ON OFF)
+ -DBUILD_STATIC=$(usex static-libs ON OFF)
+ )
+
+ cmake_src_configure
+}