summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-08-30 20:27:13 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-08-31 06:35:40 +0200
commitac6f84e82c3d1931e1e8408045c45e04dc6b1d57 (patch)
tree060b793021c325cbf65387c44def79ad37c59cc7 /dev-libs/libarcus
parentdev-perl/File-LibMagic: Keyword 1.230.0 ppc64, #738394 (diff)
downloadgentoo-ac6f84e82c3d1931e1e8408045c45e04dc6b1d57.tar.gz
gentoo-ac6f84e82c3d1931e1e8408045c45e04dc6b1d57.tar.bz2
gentoo-ac6f84e82c3d1931e1e8408045c45e04dc6b1d57.zip
dev-libs/libarcus: version bump 4.7.0
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17338 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-libs/libarcus')
-rw-r--r--dev-libs/libarcus/Manifest1
-rw-r--r--dev-libs/libarcus/libarcus-4.7.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libarcus/Manifest b/dev-libs/libarcus/Manifest
index c491ed578262..fbb9e38d5cc4 100644
--- a/dev-libs/libarcus/Manifest
+++ b/dev-libs/libarcus/Manifest
@@ -3,3 +3,4 @@ DIST libarcus-3.6.0.tar.gz 29469 BLAKE2B c032dd51631b10c04e69dac4425c8a5d180cf8c
DIST libarcus-4.2.0.tar.gz 30582 BLAKE2B cb2390d7fc8942cbdd880385313f4bd8886a1ea4eaa5246c76b0b3243e8a099953ecf51d09486e005c8c14783ec67435b33068efae2ea6075edf91b90b9fa9b2 SHA512 f9a38d095a2ba2ab29a382466ce16d1c0f5cdb34b60a2b930529edac94de177d7bed37ee26bf615833c94ccd0e3b7c71d502f5f815d92eeffdf3bc1f15b49ba5
DIST libarcus-4.3.0.tar.gz 30540 BLAKE2B 58937764d9eec4a235bcc26aa85ab1f1418ae2c576c24759fee5155c7690a3a5feee1946cbae8e7836fd4eccdb0f673167aeda46c3dae124101cfb03510697e8 SHA512 b3893e3c422de85a6968443a6f26149e9dee9f15038c11c219693b9aa8d5174d908421e33c8e3ce4e4ecab8c5077da217b44a9ec6bb4b351ff67b7f2d42cc890
DIST libarcus-4.6.1.tar.gz 31938 BLAKE2B c1da0181e07f297549df92ed23848343f0dadf94af7ce64ff2661e5c09c68768d47180aff505f2a225af2d49e493b8511ac9560a9b51a4eef98d6da82566b093 SHA512 3c56133fee2eb152f0557a1860d1d298b44a021a53247687ce938949c49e1999c3e2287552e67ff65a58bf6aecbd82c8412da394f83a9981bfa68d29e9501250
+DIST libarcus-4.7.0.tar.gz 31944 BLAKE2B 93cd7e8dab674b1e145c0fd15bcc8901982e9c26f82fa5b6b9582568701b70edeb1a589e1e1c94f9e14100d08b12580e58aa1724917b88f9c099f12ca47e4e57 SHA512 5eb8e84ff8e87966fc3ff1d71ec69f8fece493e25e022f7f1ba7ef218e75b5be86cededc28faf57634b09617990f62247e6cd6f373f940cf145ee6d8e8635374
diff --git a/dev-libs/libarcus/libarcus-4.7.0.ebuild b/dev-libs/libarcus/libarcus-4.7.0.ebuild
new file mode 100644
index 000000000000..a3f66acd8767
--- /dev/null
+++ b/dev-libs/libarcus/libarcus-4.7.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake python-single-r1
+
+MY_PN="libArcus"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libArcus"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples +python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/protobuf:=
+ $(python_gen_cond_dep '
+ dev-python/sip[${PYTHON_MULTI_USEDEP}]
+ python? ( dev-python/protobuf-python[${PYTHON_MULTI_USEDEP}] )
+ ')"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Find SIP for current python version, not the latest installed
+ sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" \
+ CMakeLists.txt cmake/FindSIP.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples ON OFF)
+ -DBUILD_PYTHON=$(usex python ON OFF)
+ -DBUILD_STATIC=$(usex static-libs ON OFF)
+ )
+
+ cmake_src_configure
+}