summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libatasmart
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libatasmart')
-rw-r--r--dev-libs/libatasmart/Manifest2
-rw-r--r--dev-libs/libatasmart/libatasmart-0.19-r1.ebuild42
-rw-r--r--dev-libs/libatasmart/libatasmart-0.19.ebuild32
-rw-r--r--dev-libs/libatasmart/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/libatasmart/Manifest b/dev-libs/libatasmart/Manifest
new file mode 100644
index 000000000000..ba5314d3e027
--- /dev/null
+++ b/dev-libs/libatasmart/Manifest
@@ -0,0 +1,2 @@
+DIST libatasmart-0.19.tar.xz 251204 SHA256 61f0ea345f63d28ab2ff0dc352c22271661b66bf09642db3a4049ac9dbdb0f8d SHA512 ec9edb019c477873b01289ba365ad0ed0946505d651c1f6f83a63ef61b3976a5db6439c8a0c74d9a55325db9a3a587ad6f655f8d1af9387b0d08356eccabdb62 WHIRLPOOL edb1296494806bbc83054110a12f703e428cfe4f340936b4393d226c702a15e97e5c6c82310fbb745d288202a9036d15eed7dd8b1ef982391dc579814db2669e
+DIST libatasmart_0.19-2.debian.tar.gz 6511 SHA256 dcfe568cd42d952b1eb633894e213f913564a0e0e62e24ae37a4578bc420ac25 SHA512 78e86b0c1d2a56dddc8d9ac97ee325871e319ad2226f1fbd5a048d792cd05e5d8162d282c1f767086da5329cd1ee67b37fbb5a2fd3c950f84e9efab11abcf754 WHIRLPOOL 127e381b100076b9c343603d4ea76cd98264643db2f3240da4a3005a3514365ff0d15f1994e99c2b06c133640f04cc68f9fdb17e7f814a3520cb9b5591a0f8a6
diff --git a/dev-libs/libatasmart/libatasmart-0.19-r1.ebuild b/dev-libs/libatasmart/libatasmart-0.19-r1.ebuild
new file mode 100644
index 000000000000..51ac79287aae
--- /dev/null
+++ b/dev-libs/libatasmart/libatasmart-0.19-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+PATCH_LEVEL=2
+
+DESCRIPTION="A small and lightweight parser library for ATA S.M.A.R.T. hard disks"
+HOMEPAGE="http://0pointer.de/blog/projects/being-smart.html"
+SRC_URI="http://0pointer.de/public/${P}.tar.xz
+ mirror://debian/pool/main/liba/${PN}/${PN}_${PV}-${PATCH_LEVEL}.debian.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README"
+
+src_prepare() {
+ # http://bugs.gentoo.org/470874
+ local d="${WORKDIR}"/debian/patches
+ sed -i -e '/#/d' "${d}"/series || die
+ EPATCH_SOURCE="${d}" epatch $(<"${d}"/series)
+}
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libatasmart/libatasmart-0.19.ebuild b/dev-libs/libatasmart/libatasmart-0.19.ebuild
new file mode 100644
index 000000000000..2cd1c629a4d0
--- /dev/null
+++ b/dev-libs/libatasmart/libatasmart-0.19.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A small and lightweight parser library for ATA S.M.A.R.T. hard disks"
+HOMEPAGE="http://0pointer.de/blog/projects/being-smart.html"
+SRC_URI="http://0pointer.de/public/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libatasmart/metadata.xml b/dev-libs/libatasmart/metadata.xml
new file mode 100644
index 000000000000..9879e83b822e
--- /dev/null
+++ b/dev-libs/libatasmart/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>