summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-08-10 09:18:42 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-08-10 09:19:00 -0400
commit29baeb6e3af67f682ed52b54fe449b8becc8bc7c (patch)
tree8bcaebb9a36d1da386a8ffa67e83f3083af6b224 /dev-libs/libbase58/libbase58-0.1.4.ebuild
parentdev-python/raet: Version bump to 0.6.8 (diff)
downloadgentoo-29baeb6e3af67f682ed52b54fe449b8becc8bc7c.tar.gz
gentoo-29baeb6e3af67f682ed52b54fe449b8becc8bc7c.tar.bz2
gentoo-29baeb6e3af67f682ed52b54fe449b8becc8bc7c.zip
dev-libs/libbase58: version bump to 1.0.4, EAPI=6 and subslot added
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libbase58/libbase58-0.1.4.ebuild')
-rw-r--r--dev-libs/libbase58/libbase58-0.1.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libbase58/libbase58-0.1.4.ebuild b/dev-libs/libbase58/libbase58-0.1.4.ebuild
new file mode 100644
index 000000000000..55a1b52188cb
--- /dev/null
+++ b/dev-libs/libbase58/libbase58-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="C implementation of Bitcoin's base58 encoding"
+HOMEPAGE="https://github.com/luke-jr/libbase58"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable tools tool)
+}