summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-06 15:07:53 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-06 15:07:53 +0100
commiteca68378026de4f1821d4131dcae4ddcbb44ab2c (patch)
tree41b4b9e3107b274fd35c2f29604a6e7783c381be /dev-libs/libbsd/libbsd-0.8.2.ebuild
parentapp-shells/zsh-completions: Version bump (diff)
downloadgentoo-eca68378026de4f1821d4131dcae4ddcbb44ab2c.tar.gz
gentoo-eca68378026de4f1821d4131dcae4ddcbb44ab2c.tar.bz2
gentoo-eca68378026de4f1821d4131dcae4ddcbb44ab2c.zip
dev-libs/libbsd: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-libs/libbsd/libbsd-0.8.2.ebuild')
-rw-r--r--dev-libs/libbsd/libbsd-0.8.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libbsd/libbsd-0.8.2.ebuild b/dev-libs/libbsd/libbsd-0.8.2.ebuild
new file mode 100644
index 000000000000..4909332ed37c
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+multilib_src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # http://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+}