summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-05-04 08:57:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-05-04 08:59:31 +0200
commit25567d0553963c8add91957d0893fac4cc15925c (patch)
tree058fb4a059a2ee4f15dd4804e71d7fbb3692311f /dev-libs/libbytesize
parentdev-python/polib: EAPI-7 revbump. Added python3_7 support. (diff)
downloadgentoo-25567d0553963c8add91957d0893fac4cc15925c.tar.gz
gentoo-25567d0553963c8add91957d0893fac4cc15925c.tar.bz2
gentoo-25567d0553963c8add91957d0893fac4cc15925c.zip
dev-libs/libbytesize: Revbump to python-single-r1 eclass. Removed old.
Added missing PYTHON_USEDEPs Thanks-to: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Closes: https://bugs.gentoo.org/685018 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libbytesize')
-rw-r--r--dev-libs/libbytesize/libbytesize-2.0-r1.ebuild (renamed from dev-libs/libbytesize/libbytesize-2.0.ebuild)8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/libbytesize/libbytesize-2.0.ebuild b/dev-libs/libbytesize/libbytesize-2.0-r1.ebuild
index 60b36285a575..2ad1b57ba581 100644
--- a/dev-libs/libbytesize/libbytesize-2.0.ebuild
+++ b/dev-libs/libbytesize/libbytesize-2.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit autotools python-any-r1
+inherit autotools python-single-r1
DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
HOMEPAGE="https://github.com/storaged-project/libbytesize"
@@ -29,8 +29,8 @@ DEPEND="
sys-devel/gettext
doc? ( dev-util/gtk-doc )
test? (
- dev-python/pocketlint
- dev-python/polib
+ dev-python/pocketlint[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
)
"
@@ -45,8 +45,8 @@ src_prepare() {
src_configure() {
local myeconfargs=(
- $(use_with python python3)
$(use_with doc gtk-doc)
+ $(use_with python python3)
$(use_with tools)
)
econf "${myeconfargs[@]}"