summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-05 09:30:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-05 09:31:03 +0200
commite1840495847d210fcce0f78e48185475f27400b3 (patch)
treed9a75d9f8b09c93cef4446040ca6016e5bd76a62 /dev-libs/libbytesize
parentnet-mail/courier-imap: Install a monthly cron job for dhparams (diff)
downloadgentoo-e1840495847d210fcce0f78e48185475f27400b3.tar.gz
gentoo-e1840495847d210fcce0f78e48185475f27400b3.tar.bz2
gentoo-e1840495847d210fcce0f78e48185475f27400b3.zip
dev-libs/libbytesize: Bump to version 2.1
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libbytesize')
-rw-r--r--dev-libs/libbytesize/Manifest1
-rw-r--r--dev-libs/libbytesize/libbytesize-2.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/Manifest b/dev-libs/libbytesize/Manifest
index aa6bbdb7f0e9..5e87d56eede5 100644
--- a/dev-libs/libbytesize/Manifest
+++ b/dev-libs/libbytesize/Manifest
@@ -1,3 +1,4 @@
DIST libbytesize-1.2.tar.gz 70598 BLAKE2B e136b1274703da7b3596e7583cea1ac773c1594af09c626f4dbb481dfcc23a3186b03ebdc54bba67d0a063c5d6587f6b7f8b610828c461cfd114eea1388dd193 SHA512 a8151e7440d0ec43d10239ddf08a9924827cdf08f20a16dff6177b444c1022fab905a0567384531e7610d854998111adb77f9a6a98e2d9648c02521f84ea2bf2
DIST libbytesize-1.4.tar.gz 80943 BLAKE2B d4c6c34d81be01bf7db2c37b0660886d99eff3c0a87024f5fbc12cc3606dc01e772b81dfbcacbf76c62213120253a9e7bda90adbc749b6d4c3e31e1ed3ae7702 SHA512 5dd13cf52a1674be776220ee1863f42261a47dc53af1ce4a31460d6d02ce87e19c5a52260f700928af98f1d9d7a96de7c11d8f384907b3187ef2effc10cbb593
DIST libbytesize-2.0.tar.gz 440544 BLAKE2B a371c617c965171a8746339ff8a2ec412daf3f79ae80e4e6a404546b0fc2f59f3e5882fc93726701490ef267f90cfd8c5db70bf7bd334c08806ff35eaab97377 SHA512 9d2a18930d0d900262ced4abd5cd358896570eadb06435f1b9aba5484ca530478b65dfb4982e8acf77ca4519a2d8a1dc236d42f5fa1ecbd7461949b282ef44a1
+DIST libbytesize-2.1.tar.gz 440209 BLAKE2B 7c689f269eae7b408b7f85fb9c877c9eb519d2a2eb143ef0ddb1657fbb4d79fab7cdaa56b35b4bbbb964e47361e37d7c70a0a135bacb8f817bd6cf8d2e22b68e SHA512 6b93d877e921820c19ed6874a36d9f8b6958112f6230f24980e8e6e30570b39ce74594f0ef126f70dc81b5434899c1f0f3ad0925f3ff7b6a596a9329c8f106c8
diff --git a/dev-libs/libbytesize/libbytesize-2.1.ebuild b/dev-libs/libbytesize/libbytesize-2.1.ebuild
new file mode 100644
index 000000000000..f3c68f3c42fe
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-2.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/storaged-project/libbytesize"
+SRC_URI="https://github.com/storaged-project/libbytesize/releases/download/${PV}/${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc python test tools"
+
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tools? ( python )
+"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:=
+ dev-libs/libpcre2
+ python? ( ${PYTHON_DEPS} )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint[${PYTHON_USEDEP}]
+ dev-python/polib[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md )
+
+RESTRICT="test"
+
+python_do() {
+ if use python; then
+ python_foreach_impl run_in_build_dir "$@"
+ else
+ "$@"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc gtk-doc)
+ $(use_with python python3)
+ $(use_with tools)
+ )
+ local ECONF_SOURCE="${S}"
+ python_do econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ python_do emake
+}
+
+src_test() {
+ python_do emake check
+}
+
+install_helper() {
+ emake DESTDIR="${D}" install
+ use python && python_optimize
+}
+
+src_install() {
+ python_do install_helper
+ einstalldocs
+ find "${ED}" -name "*.la" -type f -delete || die
+}