summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:47:58 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-04 23:23:44 +0300
commitf145467c02c0ab7bb2b3d5fb82a1b2e7152f86b7 (patch)
treedacc511c3533edc9aa1f4b1512ac0d7596d522da /dev-libs/libcbor
parentdev-lang/spidermonkey: use python_has_version inside python_check_deps (diff)
downloadgentoo-f145467c02c0ab7bb2b3d5fb82a1b2e7152f86b7.tar.gz
gentoo-f145467c02c0ab7bb2b3d5fb82a1b2e7152f86b7.tar.bz2
gentoo-f145467c02c0ab7bb2b3d5fb82a1b2e7152f86b7.zip
dev-libs/libcbor: use python_has_version inside python_check_deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-libs/libcbor')
-rw-r--r--dev-libs/libcbor/libcbor-0.9.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/libcbor/libcbor-0.9.0.ebuild b/dev-libs/libcbor/libcbor-0.9.0.ebuild
index 5878e0247683..9d2172da0ce8 100644
--- a/dev-libs/libcbor/libcbor-0.9.0.ebuild
+++ b/dev-libs/libcbor/libcbor-0.9.0.ebuild
@@ -30,8 +30,9 @@ BDEPEND="
RESTRICT="!test? ( test )"
python_check_deps() {
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
- has_version "dev-python/breathe[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/sphinx[${PYTHON_USEDEP}]" \
+ "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]" \
+ "dev-python/breathe[${PYTHON_USEDEP}]"
}
pkg_setup() {