summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2021-07-23 06:40:01 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2021-07-23 14:46:36 +0200
commit264ff9cf6a589ca40346d989cce4b2bf92aded47 (patch)
treeb4eedae05d175d5b096c4dcfedafed0bb3e40806 /dev-libs/libcharon
parentdev-libs/libcharon: byte-compile missing modules (diff)
downloadgentoo-264ff9cf6a589ca40346d989cce4b2bf92aded47.tar.gz
gentoo-264ff9cf6a589ca40346d989cce4b2bf92aded47.tar.bz2
gentoo-264ff9cf6a589ca40346d989cce4b2bf92aded47.zip
dev-libs/libcharon: drop old
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/21751 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-libs/libcharon')
-rw-r--r--dev-libs/libcharon/libcharon-4.9.1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-libs/libcharon/libcharon-4.9.1.ebuild b/dev-libs/libcharon/libcharon-4.9.1.ebuild
deleted file mode 100644
index 819af575f9c9..000000000000
--- a/dev-libs/libcharon/libcharon-4.9.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit cmake python-single-r1
-
-MY_PN="libCharon"
-
-DESCRIPTION="This library facilitates communication between Cura and its backend"
-HOMEPAGE="https://github.com/Ultimaker/libCharon"
-SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0/3"
-KEYWORDS="~amd64 ~arm64 ~x86"
-
-IUSE="+client +dbus test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="
- ${PYTHON_DEPS}
- dbus? (
- acct-group/ultimaker
- acct-user/ultimaker
- sys-apps/dbus
- )"
-
-DEPEND="${PYTHON_DEPS}
- test? (
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_prepare() {
- # use current python version, not the latest installed
- # fix python install location
- sed -i \
- -e "s:find_package(Python3 3.4 REQUIRED:find_package(Python3 ${EPYTHON##python} EXACT REQUIRED:g" \
- -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}\.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" \
- CMakeLists.txt || die
-
- sed -i -e "s:/usr/lib/python3/dist-packages/Charon/Service/main.py:$(python_get_sitedir)/Charon/Service/main.py:g" service/charon.service || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_CLIENT=$(usex client ON OFF)
- -DINSTALL_SERVICE=$(usex dbus ON OFF)
- -DPython3_EXECUTABLE="${PYTHON}"
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- python_optimize "${D}/usr/$(get_libdir)"
-}
-
-pkg_postinst() {
- if use dbus ; then
- elog "To start the Charon File Metadata service at boot, add it to the default runlevel with:"
- elog " systemctl enable charon"
- fi
-}