summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-08-30 19:18:28 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-08-31 06:36:16 +0200
commitdcf01ac58265770e794a20de4cdb2a1fcdef69be (patch)
tree68fba8671edc23384c3516b9fd9a82f8f5842823 /dev-libs/libcharon
parentdev-libs/libarcus: version bump 4.7.0 (diff)
downloadgentoo-dcf01ac58265770e794a20de4cdb2a1fcdef69be.tar.gz
gentoo-dcf01ac58265770e794a20de4cdb2a1fcdef69be.tar.bz2
gentoo-dcf01ac58265770e794a20de4cdb2a1fcdef69be.zip
dev-libs/libcharon: version bump 4.7.0
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/17236 Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-libs/libcharon')
-rw-r--r--dev-libs/libcharon/Manifest1
-rw-r--r--dev-libs/libcharon/libcharon-4.7.0.ebuild73
-rw-r--r--dev-libs/libcharon/metadata.xml6
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/libcharon/Manifest b/dev-libs/libcharon/Manifest
index a6fd1bb6f853..ade0148767f1 100644
--- a/dev-libs/libcharon/Manifest
+++ b/dev-libs/libcharon/Manifest
@@ -3,3 +3,4 @@ DIST libcharon-3.6.0.tar.gz 143947 BLAKE2B 5787f734e0d494eb9fc151fcf240c36b0ade3
DIST libcharon-4.2.0.tar.gz 145482 BLAKE2B 38f2efa1c19f81646e8b9692c57d71dda0a53fcc7c120e973f8faf55a0d92d4f8daa21e3debb873f4965f37c7e1cf0f5f1aaaebb9d078565d4fcb3edc57c9314 SHA512 4011cba788ed1789c0f364d605dfe2fc775a1f5e0ab9f0457454094f9cc3a400fdc7241692e88abae968e32e3c5394bef95cd3f77d2c68e4dbfc73ed27905b86
DIST libcharon-4.3.0.tar.gz 145484 BLAKE2B cbb0edca76921c32b69809dfa8e07c07baedba90ff3c8f2ad5128cc1efa60e34f0f96c1936567825f7e876d298ef1ed4c10d0058f5b3697f87c412891654fabb SHA512 77ed18fbd11c008659a02419250647c9c977a57772d648f4af353c637224ba586006665e60e7fa2394b9f8cf53359a6211b936b5920ccc379754a743dbf2416f
DIST libcharon-4.6.1.tar.gz 145486 BLAKE2B 43a3bcddf128da9305711757b707394b5b0c23da27e27c3615d521e0af79683b2a525fefa7ae877581b56dae4c1dd7036c3189c17f8f86c92492b46e129a22b3 SHA512 43f7606529a933067bcb82a16e95d76f713a7847535887968c2933131d3197ec6127376e10c7d5f1debd218fc902962329fe22d4f9229b434a804daff94122cc
+DIST libcharon-4.7.0.tar.gz 151221 BLAKE2B af9fe83e07303e1ff296b878c9745a329531a9957ad16a9b39b36e53f3f2275f850806b6d1a51638013c7148f3ee68b92489a67629a6026056a8c4ed3f2338b1 SHA512 690ce086bf8bba3eee2ce087d02ce00c23a7ac4079b0a2961c05cf75d461b0d5dee0c1f86ed769b50f1cd9ef83d8570a54f4fac628e0c19a5a593138292bc64c
diff --git a/dev-libs/libcharon/libcharon-4.7.0.ebuild b/dev-libs/libcharon/libcharon-4.7.0.ebuild
new file mode 100644
index 000000000000..5ebb18cff1f3
--- /dev/null
+++ b/dev-libs/libcharon/libcharon-4.7.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake python-single-r1
+
+MY_PN="libCharon"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libCharon"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+client +dbus test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dbus? (
+ acct-group/ultimaker
+ acct-user/ultimaker
+ sys-apps/dbus
+ )"
+
+DEPEND="${PYTHON_DEPS}
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_MULTI_USEDEP}]')
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ # use current python version, not the latest installed
+ # fix python install location
+ sed -i \
+ -e "s:find_package(Python3 3.4 REQUIRED:find_package(Python3 ${EPYTHON##python} EXACT REQUIRED:g" \
+ -e "s:lib\${LIB_SUFFIX}/python\${Python3_VERSION_MAJOR}\.\${Python3_VERSION_MINOR}/site-packages:$(python_get_sitedir):g" \
+ CMakeLists.txt || die
+
+ sed -i -e "s:/usr/lib/python3/dist-packages/Charon/Service/main.py:$(python_get_sitedir)/Charon/Service/main.py:g" service/charon.service || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_CLIENT=$(usex client ON OFF)
+ -DINSTALL_SERVICE=$(usex dbus ON OFF)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ python_optimize "${D}/usr/$(get_libdir)"
+}
+
+pkg_postinst() {
+ if use dbus ; then
+ elog "To start the Charon File Metadata service at boot, add it to the default runlevel with:"
+ elog " systemctl enable charon"
+ fi
+}
diff --git a/dev-libs/libcharon/metadata.xml b/dev-libs/libcharon/metadata.xml
index 56f0a7df8630..8ac90e1ed2c0 100644
--- a/dev-libs/libcharon/metadata.xml
+++ b/dev-libs/libcharon/metadata.xml
@@ -24,6 +24,12 @@
<slots>
<subslots>soname major version number</subslots>
</slots>
+ <longdescription>
+ Library to read and write several 3D-printing related file formats including G-Code and Ultimaker File Package (UFP).
+ </longdescription>
+ <use>
+ <flag name="client">Install the charon client library</flag>
+ </use>
<upstream>
<remote-id type="github">Ultimaker/libCharon</remote-id>
</upstream>