summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libcli/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libcli/files')
-rw-r--r--dev-libs/libcli/files/libcli-1.9.4-ldflags.patch11
-rw-r--r--dev-libs/libcli/files/libcli-1.9.7-libdir.patch24
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libcli/files/libcli-1.9.4-ldflags.patch b/dev-libs/libcli/files/libcli-1.9.4-ldflags.patch
new file mode 100644
index 000000000000..0dd8e13d67fc
--- /dev/null
+++ b/dev-libs/libcli/files/libcli-1.9.4-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile~ 2008-07-28 03:13:16.000000000 +0200
++++ Makefile 2010-09-12 15:39:05.000000000 +0200
+@@ -28,7 +28,7 @@
+ libcli.o: libcli.h
+
+ clitest: clitest.o $(LIB)
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $< -L. -lcli
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $< -L. -lcli
+
+ clitest.exe: clitest.c libcli.o
+ $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $< libcli.o -lws2_32
diff --git a/dev-libs/libcli/files/libcli-1.9.7-libdir.patch b/dev-libs/libcli/files/libcli-1.9.7-libdir.patch
new file mode 100644
index 000000000000..99f817095adc
--- /dev/null
+++ b/dev-libs/libcli/files/libcli-1.9.7-libdir.patch
@@ -0,0 +1,24 @@
+--- libcli-1.9.7/Makefile
++++ libcli-1.9.7/Makefile
+@@ -1,6 +1,7 @@
+ UNAME = $(shell sh -c 'uname -s 2>/dev/null || echo not')
+ DESTDIR =
+ PREFIX = /usr/local
++libdir = $(PREFIX)/lib
+
+ MAJOR = 1
+ MINOR = 9
+@@ -50,10 +51,10 @@
+ rm -f *.o $(LIB)* $(LIB_STATIC) clitest
+
+ install: $(LIB)
+- install -d $(DESTDIR)$(PREFIX)/include $(DESTDIR)$(PREFIX)/lib
++ install -d $(DESTDIR)$(PREFIX)/include $(DESTDIR)$(libdir)
+ install -m 0644 libcli.h $(DESTDIR)$(PREFIX)/include
+- install -m 0755 $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(DESTDIR)$(PREFIX)/lib
+- cd $(DESTDIR)$(PREFIX)/lib && \
++ install -m 0755 $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(DESTDIR)$(libdir)
++ cd $(DESTDIR)$(libdir) && \
+ ln -fs $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR) && \
+ ln -fs $(LIB).$(MAJOR).$(MINOR) $(LIB)
+