summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-02-13 15:16:33 -0500
committerMike Gilbert <floppym@gentoo.org>2023-02-13 19:29:25 -0500
commitb885790c3a76f426aed746cbbf1fd433d9d43451 (patch)
treee3774cefc44d7c401fdc1ce8bb7a4890f4aa2951 /dev-libs/libevent
parentwww-client/firefox: adjust libevent dependency (diff)
downloadgentoo-b885790c3a76f426aed746cbbf1fd433d9d43451.tar.gz
gentoo-b885790c3a76f426aed746cbbf1fd433d9d43451.tar.bz2
gentoo-b885790c3a76f426aed746cbbf1fd433d9d43451.zip
dev-libs/libevent: enable thread support unconditionally
Closes: https://bugs.gentoo.org/869722 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/libevent')
-rw-r--r--dev-libs/libevent/libevent-2.1.11-r1.ebuild (renamed from dev-libs/libevent/libevent-2.1.11.ebuild)7
-rw-r--r--dev-libs/libevent/libevent-2.1.12-r1.ebuild (renamed from dev-libs/libevent/libevent-2.1.12.ebuild)5
-rw-r--r--dev-libs/libevent/libevent-2.1.9999.ebuild5
-rw-r--r--dev-libs/libevent/libevent-9999.ebuild5
4 files changed, 9 insertions, 13 deletions
diff --git a/dev-libs/libevent/libevent-2.1.11.ebuild b/dev-libs/libevent/libevent-2.1.11-r1.ebuild
index 17b310f4c5ad..e7a8efedf696 100644
--- a/dev-libs/libevent/libevent-2.1.11.ebuild
+++ b/dev-libs/libevent/libevent-2.1.11-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,7 @@ LICENSE="BSD"
SLOT="0/2.1-7"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug +ssl static-libs test +threads"
+IUSE="debug +ssl static-libs test"
RESTRICT="!test? ( test )"
DEPEND="
@@ -44,8 +44,7 @@ multilib_src_configure() {
$(use_enable debug malloc-replacement) \
$(use_enable ssl openssl) \
$(use_enable static-libs static) \
- $(use_enable test libevent-regress) \
- $(use_enable threads thread-support)
+ $(use_enable test libevent-regress)
}
src_test() {
diff --git a/dev-libs/libevent/libevent-2.1.12.ebuild b/dev-libs/libevent/libevent-2.1.12-r1.ebuild
index 0098608db527..2077b9fd606f 100644
--- a/dev-libs/libevent/libevent-2.1.12.ebuild
+++ b/dev-libs/libevent/libevent-2.1.12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ SLOT="0/2.1-7"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="
+clock-gettime debug malloc-replacement +ssl static-libs test
- +threads verbose-debug
+ verbose-debug
"
RESTRICT="!test? ( test )"
@@ -55,7 +55,6 @@ multilib_src_configure() {
$(use_enable ssl openssl) \
$(use_enable static-libs static) \
$(use_enable test libevent-regress) \
- $(use_enable threads thread-support) \
$(use_enable verbose-debug) \
--disable-samples
}
diff --git a/dev-libs/libevent/libevent-2.1.9999.ebuild b/dev-libs/libevent/libevent-2.1.9999.ebuild
index 842a86badc67..41545a096b4c 100644
--- a/dev-libs/libevent/libevent-2.1.9999.ebuild
+++ b/dev-libs/libevent/libevent-2.1.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ SLOT="0/2.1-7"
KEYWORDS=""
IUSE="
+clock-gettime debug malloc-replacement +ssl static-libs test
- +threads verbose-debug
+ verbose-debug
"
RESTRICT="test"
@@ -56,7 +56,6 @@ multilib_src_configure() {
$(use_enable ssl openssl) \
$(use_enable static-libs static) \
$(use_enable test libevent-regress) \
- $(use_enable threads thread-support) \
$(use_enable verbose-debug) \
--disable-samples
}
diff --git a/dev-libs/libevent/libevent-9999.ebuild b/dev-libs/libevent/libevent-9999.ebuild
index c9777c12daf2..f5619ac0a1b0 100644
--- a/dev-libs/libevent/libevent-9999.ebuild
+++ b/dev-libs/libevent/libevent-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS=""
IUSE="
+clock-gettime debug malloc-replacement mbedtls +ssl static-libs
- test +threads verbose-debug
+ test verbose-debug
"
RESTRICT="test"
@@ -56,7 +56,6 @@ multilib_src_configure() {
$(use_enable ssl openssl) \
$(use_enable static-libs static) \
$(use_enable test libevent-regress) \
- $(use_enable threads thread-support) \
$(use_enable verbose-debug) \
--disable-samples
}