summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-06 07:52:44 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-06 07:53:11 +0200
commitf133f4cfa8e73355ce7c31894430ec4c4a5986d2 (patch)
tree32fe7c193829b5e77ad9e18b99e421339aac46f5 /dev-libs/libevent
parentnet-analyzer/mtr: Version 0.93 (diff)
downloadgentoo-f133f4cfa8e73355ce7c31894430ec4c4a5986d2.tar.gz
gentoo-f133f4cfa8e73355ce7c31894430ec4c4a5986d2.tar.bz2
gentoo-f133f4cfa8e73355ce7c31894430ec4c4a5986d2.zip
dev-libs/libevent: Version 2.1.11
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs/libevent')
-rw-r--r--dev-libs/libevent/Manifest1
-rw-r--r--dev-libs/libevent/libevent-2.1.11.ebuild60
-rw-r--r--dev-libs/libevent/libevent-2.1.9999.ebuild2
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-libs/libevent/Manifest b/dev-libs/libevent/Manifest
index ee99d13b7a94..2cc947cd10b4 100644
--- a/dev-libs/libevent/Manifest
+++ b/dev-libs/libevent/Manifest
@@ -1,2 +1,3 @@
DIST libevent-2.1.10.tar.gz 1074897 BLAKE2B 15c86f9d82a54912dc8ebde54192e77dc105a9b7fab215a3ba0b85de31e9caccef8aa02ace0172e22ee394cff0e7b5a4e8ff2a8c5c3e472378630f66b1c0d33b SHA512 2a449b60c5bba0908f693d3169a2941f0952b462ea18cf3c7a7288cd902592f35a42c76096af502f04259ffce2567233fda3586578c2ac53fbfce6e00d35c086
+DIST libevent-2.1.11.tar.gz 1082234 BLAKE2B c6721589834bff027a8149ee0076e1877fba000d1712a405e20030192d9c81b892d0930bc1a4774650bef4cb08c60ac81b5928dc17346492ae7e4ded2125579a SHA512 9d0517b117f128f4f196b19a810524814bab75fa967d533063aaa619d3cf2dca97b443edd5805b764da2993d8e37caa536dce39f68ffcc2a88d32a89204c2de3
DIST libevent-2.1.8.tar.gz 1026485 BLAKE2B f1ceb740aa776a7c26f52916d771af7f4bb351cadf858ef991ab015e5897e34579c6af1f4ed3b516d5be2ac7cb3a7c27ac9d3020dbb04ac7670118616a264561 SHA512 a2fd3dd111e73634e4aeb1b29d06e420b15c024d7b47778883b5f8a4ff320b5057a8164c6d50b53bd196c79d572ce2639fe6265e03a93304b09c22b41e4c2a17
diff --git a/dev-libs/libevent/libevent-2.1.11.ebuild b/dev-libs/libevent/libevent-2.1.11.ebuild
new file mode 100644
index 000000000000..aab84dca42b3
--- /dev/null
+++ b/dev-libs/libevent/libevent-2.1.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="Library to execute a function when a specific event occurs on a file descriptor"
+HOMEPAGE="https://libevent.org/ https://github.com/libevent/libevent/"
+SRC_URI="
+ https://github.com/${PN}/${PN}/releases/download/release-${PV/_/-}-stable/${P/_/-}-stable.tar.gz -> ${P}.tar.gz
+"
+LICENSE="BSD"
+
+SLOT="0/2.1-7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug libressl +ssl static-libs test +threads"
+
+DEPEND="
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/9libs-1.0
+"
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/event2/event-config.h
+)
+S=${WORKDIR}/${P/_/-}-stable
+
+multilib_src_configure() {
+ # fix out-of-source builds
+ mkdir -p test || die
+
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-samples \
+ $(use_enable debug debug-mode) \
+ $(use_enable debug malloc-replacement) \
+ $(use_enable ssl openssl) \
+ $(use_enable static-libs static) \
+ $(use_enable test libevent-regress) \
+ $(use_enable threads thread-support)
+}
+
+src_test() {
+ # The test suite doesn't quite work (see bug #406801 for the latest
+ # installment in a riveting series of reports).
+ :
+ # emake -C test check | tee "${T}"/tests
+}
+
+DOCS=( ChangeLog{,-1.4,-2.0} )
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libevent/libevent-2.1.9999.ebuild b/dev-libs/libevent/libevent-2.1.9999.ebuild
index 0a40893390d8..cf4e7dfeb381 100644
--- a/dev-libs/libevent/libevent-2.1.9999.ebuild
+++ b/dev-libs/libevent/libevent-2.1.9999.ebuild
@@ -14,7 +14,7 @@ HOMEPAGE="
LICENSE="BSD"
# libevent-2.1.so.6
-SLOT="0/2.1-6"
+SLOT="0/2.1-7"
KEYWORDS=""
IUSE="debug libressl +ssl static-libs test +threads"
RESTRICT="test"