summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-07-05 11:13:45 -0400
committerCraig Andrews <candrews@gentoo.org>2018-07-05 11:15:00 -0400
commit4e544119b284b22208b921d5d0a97a77bc9154f1 (patch)
treeb8d328c20f9256f0b6aae8e2e1729b74e066ecda /dev-libs/libfmt/libfmt-5.1.0.ebuild
parentsys-boot/systemrescuecd-x86-grub: Fix path of ISO image. (diff)
downloadgentoo-4e544119b284b22208b921d5d0a97a77bc9154f1.tar.gz
gentoo-4e544119b284b22208b921d5d0a97a77bc9154f1.tar.bz2
gentoo-4e544119b284b22208b921d5d0a97a77bc9154f1.zip
dev-libs/libfmt: 5.1.0 version bump
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libfmt/libfmt-5.1.0.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-5.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-5.1.0.ebuild b/dev-libs/libfmt/libfmt-5.1.0.ebuild
new file mode 100644
index 000000000000..205d52c52e72
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-5.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib versionator
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="BSD-2"
+IUSE="test"
+SLOT="0/$(get_major_version)"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}