summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-01-07 10:25:00 -0500
committerCraig Andrews <candrews@gentoo.org>2022-01-07 10:25:33 -0500
commit268866059128350ec17701c738dba9022a2d2989 (patch)
tree1f16feb4a54cde7eb2023d1ee01062ab97f72d6a /dev-libs/libfmt
parentdev-vcs/hg-git-0.10.3: version bump (diff)
downloadgentoo-268866059128350ec17701c738dba9022a2d2989.tar.gz
gentoo-268866059128350ec17701c738dba9022a2d2989.tar.bz2
gentoo-268866059128350ec17701c738dba9022a2d2989.zip
dev-libs/libfmt: 8.1.1 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libfmt')
-rw-r--r--dev-libs/libfmt/Manifest1
-rw-r--r--dev-libs/libfmt/libfmt-8.1.1.ebuild36
-rw-r--r--dev-libs/libfmt/libfmt-9999.ebuild6
3 files changed, 40 insertions, 3 deletions
diff --git a/dev-libs/libfmt/Manifest b/dev-libs/libfmt/Manifest
index 022c7f0b41e6..1bcda92fef5a 100644
--- a/dev-libs/libfmt/Manifest
+++ b/dev-libs/libfmt/Manifest
@@ -2,3 +2,4 @@ DIST libfmt-7.1.2.tar.gz 769401 BLAKE2B 66a14197a818cbc63e2219eb9f8aeb47cc575a71
DIST libfmt-7.1.3.tar.gz 770029 BLAKE2B 745440a6f5876d47d4651d007d5968f77d8f5ac01ab5ec17ec5851130a5581e2aa7d359ae297ce7318023b0bf386f9c027e3e38c65f297ae874e607253a3493a SHA512 cfb2431de822202f17a6f34a302b1922b9cd696d8d4c27ad50ea08add781d2af9944db987603c2eb294ee7d73054a60cc11d3a0693f7f6db61949f3041cb9517
DIST libfmt-8.0.0.tar.gz 804902 BLAKE2B 9330acbfb6ab47a484b4dbd3138d11cdd79f4233dfe8fefed41d67118eb19b2c00db5896ee883e2f5ff297170c2eb8dfa001cc6d7c6eff42b6285acd0ea91b5c SHA512 61768bf8b64c430f11536800985509ce436bbbe05cbe1dfb6045cfaf2f859af98eae1019ef602af8fec6946ae25e4d8adb589f0f738666b20beb3afe65ee760c
DIST libfmt-8.0.1.tar.gz 805616 BLAKE2B b64a4686050a9edb4e5d3ec28a3727a847105ae0b12a89461841e14d6c9c442e391cdcfbca39b2d141d04cdb10d00516ecc8bf605867c792b7d2d6bc99c7b2bc SHA512 643e68d5b2e0e9c83231ab2b0036596a6297b1d9ed6bd7b1172bee4ff134c8af8f09174c06c94225132c1b635b0977ea4ce783748d7bd76a9a0b5ad597456c84
+DIST libfmt-8.1.1.tar.gz 826254 BLAKE2B 8f3eafd72c0eff62cfcf26a8a37e4d89c8f4a2cec6e427e3ea8d0de3010dd6e5e45ce4486335d3b433308a967915b38ca4d422d789ceda4196153329128056b9 SHA512 794a47d7cb352a2a9f2c050a60a46b002e4157e5ad23e15a5afc668e852b1e1847aeee3cda79e266c789ff79310d792060c94976ceef6352e322d60b94e23189
diff --git a/dev-libs/libfmt/libfmt-8.1.1.ebuild b/dev-libs/libfmt/libfmt-8.1.1.ebuild
new file mode 100644
index 000000000000..02ef483ce0e4
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-8.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="MIT"
+IUSE="test"
+SLOT="0/${PV}"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/libfmt/libfmt-9999.ebuild b/dev-libs/libfmt/libfmt-9999.ebuild
index 376757b05ade..02ef483ce0e4 100644
--- a/dev-libs/libfmt/libfmt-9999.ebuild
+++ b/dev-libs/libfmt/libfmt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,14 +11,14 @@ HOMEPAGE="https://github.com/fmtlib/fmt"
LICENSE="MIT"
IUSE="test"
-SLOT="0/$(ver_cut 1)"
+SLOT="0/${PV}"
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
inherit git-r3
else
SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
S="${WORKDIR}/fmt-${PV}"
fi