summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-16 18:44:45 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-01-16 18:45:59 -0800
commitd8a4d3fd80741ffdbd17dff2e5ecfde4220c96ab (patch)
tree282b49dcc3674dd4cf87f4549c2736dd17f4480b /dev-libs/libgcrypt
parentmedia-video/shotcut: crank up MLT lower bound (diff)
downloadgentoo-d8a4d3fd80741ffdbd17dff2e5ecfde4220c96ab.tar.gz
gentoo-d8a4d3fd80741ffdbd17dff2e5ecfde4220c96ab.tar.bz2
gentoo-d8a4d3fd80741ffdbd17dff2e5ecfde4220c96ab.zip
dev-libs/libgcrypt: add cpu_flags_ppc_vsx2
to control new configure knob --disable-ppc-crypto-support Disable support for the PPC crypto instructions introduced in POWER 8 (PowerISA 2.07) Closes: https://bugs.gentoo.org/825722 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.9.4.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.9.4.ebuild b/dev-libs/libgcrypt/libgcrypt-1.9.4.ebuild
index 544ba718baee..c7244661f75b 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.9.4.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.9.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1 MIT"
SLOT="0/20" # subslot = soname major version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+asm cpu_flags_arm_neon cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc o-flag-munging static-libs"
+IUSE="+asm cpu_flags_arm_neon cpu_flags_ppc_vsx2 cpu_flags_x86_aes cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_padlock cpu_flags_x86_sha cpu_flags_x86_sse4_1 doc o-flag-munging static-libs"
RDEPEND=">=dev-libs/libgpg-error-1.25[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}"
@@ -44,6 +44,7 @@ multilib_src_configure() {
--enable-noexecstack
$(use_enable cpu_flags_arm_neon neon-support)
+ $(use_enable cpu_flags_ppc_vsx2 ppc-crypto-support)
$(use_enable cpu_flags_x86_aes aesni-support)
$(use_enable cpu_flags_x86_avx avx-support)
$(use_enable cpu_flags_x86_avx2 avx2-support)