summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-08 11:36:23 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-08 11:50:56 +0200
commitfda0797ea93c90eeace3c3f057e2a999fa591b29 (patch)
tree1993222c9a67c852bec1c0b2f4ca91975fad61e1 /dev-libs/libgdata/libgdata-0.17.6.ebuild
parentgnome-extra/gucharmap: Version bump (diff)
downloadgentoo-fda0797ea93c90eeace3c3f057e2a999fa591b29.tar.gz
gentoo-fda0797ea93c90eeace3c3f057e2a999fa591b29.tar.bz2
gentoo-fda0797ea93c90eeace3c3f057e2a999fa591b29.zip
dev-libs/libgdata: Version bump
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-libs/libgdata/libgdata-0.17.6.ebuild')
-rw-r--r--dev-libs/libgdata/libgdata-0.17.6.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/libgdata/libgdata-0.17.6.ebuild b/dev-libs/libgdata/libgdata-0.17.6.ebuild
new file mode 100644
index 000000000000..8b19917384ca
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.17.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/22" # subslot = libgdata soname version
+
+IUSE="+crypt gnome-online-accounts +introspection static-libs test vala"
+REQUIRED_USE="
+ gnome-online-accounts? ( crypt )
+ vala? ( introspection )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# configure checks for gtk:3, but only uses it for demos which are not installed
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/json-glib-0.15
+ >=dev-libs/libxml2-2:2
+ >=net-libs/liboauth-0.9.4
+ >=net-libs/libsoup-2.42.0:2.4[introspection?]
+ >=x11-libs/gdk-pixbuf-2.14:2
+ crypt? ( app-crypt/gcr:= )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ test? ( >=net-libs/uhttpmock-0.5 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable crypt gnome) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_enable static-libs static) \
+ $(use_enable test always-build-tests)
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ export GSETTINGS_BACKEND="memory" #486412
+ dbus-launch emake check
+}